1.5.2 galatic probs

Discussion in 'Support' started by Fried, May 19, 2013.

Thread Status:
Not open for further replies.
  1. Fried

    Fried Member

    Joined:
    May 19, 2013
    Messages:
    1
    Likes Received:
    0
    just saw this mod but every time I try to use it i get the message that forge is out of date (I know its not as I am using the latest one for 1.5.2)
     

    Attached Files:

Thread Status:
Not open for further replies.

Share This Page