Addon [1.7.10 & 1.8.9 & 1.10.2 & 1.11.2 & 1.12.2] Extra Planets *Updated 24/04/2020*

MJRLegends

Member
Mar 13, 2015
526
63
28
---------------------------------------------------------------------------------------------------------------------------------
1.11.2 Version
Please report them here and use [1.11.2] in the title.
Requires Galacticraft 4 Builds, (119 Build and higher) and Forge 13.20.1.2513 or higher & Requires MJRLegendsLib v1.0.1 as of ExtraPlanets v0.5.0!

v0.5.2 is available, check change log for details
---------------------------------------------------------------------------------------------------------------------------------
1.10.2 Version
Please report them here and use [1.10.2] in the title.
Requires Galacticraft 4 Builds, (119 Build and higher) and Forge 12.18.3.2239 or higher & Requires MJRLegendsLib v1.0.1 as of ExtraPlanets v0.8.6!

v0.8.8 is available, check change log for details
---------------------------------------------------------------------------------------------------------------------------------
1.8.9 Version:
Please report them here and use [1.8] in the title.
Requires Galacticraft 4 Builds, (119 Build and higher) and Forge 11.15.1.1764 or higher & Requires MJRLegendsLib v1.0.1 as of ExtraPlanets v1.1.9!

v1.2.1 is available, check change log for details.
---------------------------------------------------------------------------------------------------------------------------------
1.7.10 Version:
Please report them here and use [1.7.10] in the title.
Requires Galacticraft 3 Builds, (493 Build and higher) and Forge 10.13.4.1614!

v1.9.3 is available, check change log for details.
---------------------------------------------------------------------------------------------------------------------------------
 
Last edited:

MJRLegends

Member
Mar 13, 2015
526
63
28
---------------------------------------------------------------------------------------------------------------------------------
1.7.10 Version:
Please report them here and use [1.7.10] in the title.
Requires Galacticraft 3 Builds, (493 Build and higher) and Forge 10.13.4.1614!

v1.9.4 is available, check change log for details.
---------------------------------------------------------------------------------------------------------------------------------
 
Last edited:

MJRLegends

Member
Mar 13, 2015
526
63
28
---------------------------------------------------------------------------------------------------------------------------------
1.11.2 Version
Please report them here and use [1.11.2] in the title.
Requires Galacticraft 4 Builds, (119 Build and higher) and Forge 13.20.1.2513 or higher & Requires MJRLegendsLib v1.0.1 as of ExtraPlanets v0.5.0!

v0.5.3 is available, check change log for details
---------------------------------------------------------------------------------------------------------------------------------
1.10.2 Version
Please report them here and use [1.10.2] in the title.
Requires Galacticraft 4 Builds, (119 Build and higher) and Forge 12.18.3.2239 or higher & Requires MJRLegendsLib v1.0.1 as of ExtraPlanets v0.8.6!

v0.8.9 is available, check change log for details
---------------------------------------------------------------------------------------------------------------------------------
1.8.9 Version:
Please report them here and use [1.8] in the title.
Requires Galacticraft 4 Builds, (119 Build and higher) and Forge 11.15.1.1764 or higher & Requires MJRLegendsLib v1.0.1 as of ExtraPlanets v1.1.9!

v1.2.2 is available, check change log for details.
---------------------------------------------------------------------------------------------------------------------------------
 

MJRLegends

Member
Mar 13, 2015
526
63
28
Translators Information:
If you would like to help then open up one of the links below and if the file doesn't exist for that language already then please take the en_US.lang file and translate from that one.

Any lines that need translating within the current lang files have the tag "##NEEDS TRANSLATE##"

1.7.10, 1.8.9, 1.10.2, 1.11.2, 1.12.2:
https://github.com/MJRLegends/ExtraPlanets/tree/master/src/main/resources/assets/extraplanets/lang

Note: All versions use the same lang file

You can submit a pull request or you can make a issue report containing the file!
 

MJRLegends

Member
Mar 13, 2015
526
63
28
---------------------------------------------------------------------------------------------------------------------------------
1.11.2 Version
Please report them here and use [1.11.2] in the title.
Requires Galacticraft 4 Builds, (119 Build and higher) and Forge 13.20.1.2513 or higher & Requires MJRLegendsLib as of ExtraPlanets v0.5.0!

v0.5.4 is available, check change log for details
---------------------------------------------------------------------------------------------------------------------------------
1.10.2 Version
Please report them here and use [1.10.2] in the title.
Requires Galacticraft 4 Builds, (119 Build and higher) and Forge 12.18.3.2239 or higher & Requires MJRLegendsLib as of ExtraPlanets v0.8.6!

v0.9.0 is available, check change log for details
---------------------------------------------------------------------------------------------------------------------------------
1.8.9 Version:
Please report them here and use [1.8] in the title.
Requires Galacticraft 4 Builds, (119 Build and higher) and Forge 11.15.1.1764 or higher & Requires MJRLegendsLib as of ExtraPlanets v1.1.9!

v1.2.3 is available, check change log for details.
---------------------------------------------------------------------------------------------------------------------------------
 

MJRLegends

Member
Mar 13, 2015
526
63
28
---------------------------------------------------------------------------------------------------------------------------------
1.7.10 Version:
Please report them here and use [1.7.10] in the title.
Requires Galacticraft 3 Builds, (493 Build and higher) and Forge 10.13.4.1614!

v1.9.5 is available, check change log for details.
---------------------------------------------------------------------------------------------------------------------------------
 
Last edited:

MJRLegends

Member
Mar 13, 2015
526
63
28
---------------------------------------------------------------------------------------------------------------------------------
1.12.2 Version:
Please report them here and use [1.12.2] in the title.
Requires Galacticraft 4 Builds, (2 Build and higher) and Forge 14.23.1.2555 or higher & Requires MJRLegendsLib as of ExtraPlanets!

v1.0.0 - v1.0.5 is available, check change log for details.
---------------------------------------------------------------------------------------------------------------------------------
 

MJRLegends

Member
Mar 13, 2015
526
63
28
---------------------------------------------------------------------------------------------------------------------------------
1.11.2 Version
Please report them here and use [1.11.2] in the title.
Requires Galacticraft 4 Builds, (122 Build and higher) and Forge 13.20.1.2513 or higher & Requires MJRLegendsLib as of ExtraPlanets v0.5.0!

v0.5.5 is available, check change log for details
---------------------------------------------------------------------------------------------------------------------------------
1.10.2 Version
Please report them here and use [1.10.2] in the title.
Requires Galacticraft 4 Builds, (122 Build and higher) and Forge 12.18.3.2239 or higher & Requires MJRLegendsLib as of ExtraPlanets v0.8.6!

v0.9.1 is available, check change log for details
---------------------------------------------------------------------------------------------------------------------------------
1.8.9 Version:
Please report them here and use [1.8] in the title.
Requires Galacticraft 4 Builds, (122 Build and higher) and Forge 11.15.1.1764 or higher & Requires MJRLegendsLib as of ExtraPlanets v1.1.9!

v1.2.4 is available, check change log for details.
---------------------------------------------------------------------------------------------------------------------------------
 

MJRLegends

Member
Mar 13, 2015
526
63
28
---------------------------------------------------------------------------------------------------------------------------------
1.12.2 Version:
Please report them here and use [1.12.2] in the title.
Requires Galacticraft 4 Builds, (128 Build and higher) and Forge 14.23.1.2555 or higher & Requires MJRLegendsLib as of ExtraPlanets!

v1.0.6 is available, check change log for details.
---------------------------------------------------------------------------------------------------------------------------------
1.11.2 Version
Please report them here and use [1.11.2] in the title.
Requires Galacticraft 4 Builds, (128 Build and higher) and Forge 13.20.1.2513 or higher & Requires MJRLegendsLib as of ExtraPlanets v0.5.0!

v0.5.6 is available, check change log for details
---------------------------------------------------------------------------------------------------------------------------------
1.10.2 Version
Please report them here and use [1.10.2] in the title.
Requires Galacticraft 4 Builds, (128 Build and higher) and Forge 12.18.3.2239 or higher & Requires MJRLegendsLib as of ExtraPlanets v0.8.6!

v0.9.2 is available, check change log for details
---------------------------------------------------------------------------------------------------------------------------------
1.8.9 Version:
Please report them here and use [1.8] in the title.
Requires Galacticraft 4 Builds, (128 Build and higher) and Forge 11.15.1.1764 or higher & Requires MJRLegendsLib as of ExtraPlanets v1.1.9!

v1.2.5 is available, check change log for details.
---------------------------------------------------------------------------------------------------------------------------------
 

MJRLegends

Member
Mar 13, 2015
526
63
28
---------------------------------------------------------------------------------------------------------------------------------
1.7.10 Version:
Please report them here and use [1.7.10] in the title.
Requires Galacticraft 3 Builds, (493 Build and higher) and Forge 10.13.4.1614!

v1.9.6 is available, check change log for details.
---------------------------------------------------------------------------------------------------------------------------------
 
Last edited:

MJRLegends

Member
Mar 13, 2015
526
63
28
---------------------------------------------------------------------------------------------------------------------------------
1.12.2 Version:
Please report them here and use [1.12.2] in the title.
Requires Galacticraft 4 Builds, (128 Build and higher) and Forge 14.23.1.2555 or higher & Requires MJRLegendsLib as of ExtraPlanets!


v0.1.7 is available, check change log for details.
---------------------------------------------------------------------------------------------------------------------------------

1.11.2 Version
Please report them here and use [1.11.2] in the title.
Requires Galacticraft 4 Builds, (128 Build and higher) and Forge 13.20.1.2513 or higher & Requires MJRLegendsLib as of ExtraPlanets v0.5.0!

v0.5.7 is available, check change log for details
---------------------------------------------------------------------------------------------------------------------------------
1.10.2 Version
Please report them here and use [1.10.2] in the title.
Requires Galacticraft 4 Builds, (128 Build and higher) and Forge 12.18.3.2239 or higher & Requires MJRLegendsLib as of ExtraPlanets v0.8.6!

v0.9.3 is available, check change log for details
---------------------------------------------------------------------------------------------------------------------------------
1.8.9 Version:
Please report them here and use [1.8] in the title.
Requires Galacticraft 4 Builds, (128 Build and higher) and Forge 11.15.1.1764 or higher & Requires MJRLegendsLib as of ExtraPlanets v1.1.9!

v1.2.6 is available, check change log for details.
---------------------------------------------------------------------------------------------------------------------------------
 
Last edited:

MJRLegends

Member
Mar 13, 2015
526
63
28
---------------------------------------------------------------------------------------------------------------------------------
1.12.2 Version:
Please report them here and use [1.12.2] in the title.
Requires Galacticraft 4 Builds, (128 Build and higher) and Forge 14.23.1.2555 or higher & Requires MJRLegendsLib as of ExtraPlanets!


v0.1.8 is available, check change log for details.
---------------------------------------------------------------------------------------------------------------------------------

1.11.2 Version
Please report them here and use [1.11.2] in the title.
Requires Galacticraft 4 Builds, (128 Build and higher) and Forge 13.20.1.2513 or higher & Requires MJRLegendsLib as of ExtraPlanets v0.5.0!

v0.5.8 is available, check change log for details
---------------------------------------------------------------------------------------------------------------------------------
 
Last edited:

MJRLegends

Member
Mar 13, 2015
526
63
28
---------------------------------------------------------------------------------------------------------------------------------
1.12.2 Version:
Please report them here and use [1.12.2] in the title.
Requires Galacticraft 4 Builds, (132 Build and higher) and Forge 14.23.1.2555 or higher & Requires MJRLegendsLib as of ExtraPlanets!


v0.1.9 is available, check change log for details.

NOTE: YOU WILL GET A MESSAGE SAYING 51 EXTRA PLANETS BIOMES HAVE BEEN REMOVED ON OLD WORLDS, IT WILL CHANGE BIOME NAMES ALL IN EXTRA PLANETS DIMENSIONS TO PLAINS BIOMES

TO FIX DELETE ALL EXTRA PLANETS DIMENSIONS FILES!!!! PLEASE DON'T REPORT AS A BUG ITS INTENDED



Dimension ids: -13, -15, -16, -17, -18, -19, -20, -21, -22, -32, -34, -33, -35, -36, -37, -38, -39, -40, -41, -42, -43

---------------------------------------------------------------------------------------------------------------------------------
 
Last edited:

MJRLegends

Member
Mar 13, 2015
526
63
28
---------------------------------------------------------------------------------------------------------------------------------
1.11.2 Version
Please report them here and use [1.11.2] in the title.
Requires Galacticraft 4 Builds, (128 Build and higher) and Forge 13.20.1.2513 or higher & Requires MJRLegendsLib as of ExtraPlanets v0.5.0!

v0.5.9 is available, check change log for details
---------------------------------------------------------------------------------------------------------------------------------
1.10.2 Version
Please report them here and use [1.10.2] in the title.
Requires Galacticraft 4 Builds, (128 Build and higher) and Forge 12.18.3.2239 or higher & Requires MJRLegendsLib as of ExtraPlanets v0.8.6!

v0.9.4 is available, check change log for details
---------------------------------------------------------------------------------------------------------------------------------
1.8.9 Version:
Please report them here and use [1.8] in the title.
Requires Galacticraft 4 Builds, (128 Build and higher) and Forge 11.15.1.1764 or higher & Requires MJRLegendsLib as of ExtraPlanets v1.1.9!

v1.2.7 is available, check change log for details.
---------------------------------------------------------------------------------------------------------------------------------
 

MJRLegends

Member
Mar 13, 2015
526
63
28
---------------------------------------------------------------------------------------------------------------------------------
1.7.10 Version:
Please report them here and use [1.7.10] in the title.
Requires Galacticraft 3 Builds, (493 Build and higher) and Forge 10.13.4.1614!

v1.9.7 is available, check change log for details.
---------------------------------------------------------------------------------------------------------------------------------
 
Last edited:

MJRLegends

Member
Mar 13, 2015
526
63
28
---------------------------------------------------------------------------------------------------------------------------------
1.12.2 Version:
Please report them here and use [1.12.2] in the title.
Requires Galacticraft 4 Builds, (132 Build and higher) and Forge 14.23.1.2555 or higher & Requires MJRLegendsLib as of ExtraPlanets!


v0.2.0 is available, check change log for details.

NOTE: MAKE SURE TO CHECK OUT V0.1.9 CHANGE LOG IF YOU UPDATING FROM A VERSION BEFORE V0.1.9

---------------------------------------------------------------------------------------------------------------------------------
 
Last edited:

MJRLegends

Member
Mar 13, 2015
526
63
28
---------------------------------------------------------------------------------------------------------------------------------
1.12.2 Version:
Please report them here and use [1.12.2] in the title.
Requires Galacticraft 4 Builds, (132 Build and higher) and Forge 14.23.1.2555 or higher & Requires MJRLegendsLib as of ExtraPlanets!


v0.2.1 is available, check change log for details.

NOTE: THERE WAS A LITTLE ISSUE WITH SOME DIMENSIONS,
IF YOUR STILL GETTING THE PLAINS BIOME NAMING ISSUE,
PLEASE USE THIS VERSION AND DELETE THAT DIMENSION.

SORRY FOR ANY TROUBLE CAUSED

---------------------------------------------------------------------------------------------------------------------------------