Astro Miner Causing Damage

May 19, 2018
3
0
1
41
Please be kind. I've asked the creator of SevTech and he has no idea so I figured I'd give the forums here a shot.

When I updated from SevTech Ages 3.0.6 to 3.0.7 and moved my save over it seems that using the Astro Miner causes damage to be taken only when it mines a rock. I'm not sure why, but would really like some help in figuring it out as I would really like to use the miner to gather resources but can't stay in any dimension without receiving damage and literally dying sooner or later. I'm not sure about all, but as far as Mercury and the asteroid belt goes this seems to be the case.

If there is anything else I can provide to help please let me know. Thanx in advanced for any help anyone can lend.

Some info:
Forge version for SevTech 3.0.6 - 14.23.2.2651
Forge version for SevTech 3.0.7 - 14.23.3.2679

Galacticraft Tweaker for SevTech 3.0.6 - 1.12.2-1.0.1
GalacticraftCore for SevTech 3.0.6 - 1.12.2-4.0.1.170
GalacticraftC-Planets for SevTech 3.0.6 -1.12.2-4.0.1.170
Extra Planets for SevTech 3.0.6 - 1.12.2-0.3.2
MicdoodleCore for SevTech 3.0.6 - 1.12.2-4.0.1.170

Galacticraft Tweaker for SevTech 3.0.7 - 1.12.2-1.0.1
GalacticraftCore for SevTech 3.0.7 - 1.12.2-4.0.1.176
GalacticraftC-Planets for SevTech 3.0.7 - 1.12.2-4.0.1.176
Extra Planets for SevTech 3.0.7 - 1.12.2-0.3.3
MicdoodleCore for SevTech 3.0.7 - 1.12.2-4.0.1.176
 

radfast

Administrator
Staff member
Apr 27, 2014
1,142
353
83
Could be an Extra Planets issue - any SevTech / Extra Planets players here care to comment?

Extra Planets adds a whole load of damage sources like radiation and pressure, which I don't really like too much in terms of game design because you have to grind so much and can die too easily. But their space suits look nice...

Please explain more what you mean by "using the Astro Miner causes damage to be taken only when it mines a rock"? Who is taking damage here (the player / the Astro Miner / the rock?)

There's nothing in our own Galacticraft code which links an Astro Miner to player damage, in any way at all, so this behaviour is most likely Extra Planets or another mod.

You can maybe help us to find a fix if you can please try this:

* backup your mods folder and make a new mods folder which has only Galacticraft 176 in it + other essentials (MicdoodleCore and JEI)

* run Minecraft, make a new world (don't damage your existing save), and try out an Astro Miner, see what happens

* if that works OK without the problem, now add Extra Planets to your mods folder, run Minecraft and try an Astro Miner in a few dimensions like the Asteroids belt or Mercury.
 
May 19, 2018
3
0
1
41
What I mean by taking damage when it mines is once the miner enters into mining mode which you can see through the Astro Base gui is when it actually mines a block, each block it mines takes half a heart from the player along with hunger and damage to the space suit. Eventually the hearts, and hunger are depleted and the suit is broken and destroyed. I will give that a try now. Thanx for your response.
 
May 19, 2018
3
0
1
41
Ok so I created a new custom profile in the twitch app and added Galacticraft Core, Galacticraft Planets, and JEI. Tested it in the overworld without issue. Added Extraplanets to the pack and went to the Asteroid belt same thing no issue.

So I went back to SevTech 3.0.6 and updated to 3.0.7 with a new profile to do some more testing.

I found something weird tied to it. Its the hopper. When I attach a hopper to the bottom to extract the contents and send them to a crate for extra storage the player takes damage. I remove the hopper no damage. I've tried from the bottom of all 4 blocks to the astro base and its the same thing.

And then it gets weirder. Right as I posted this my oxygen ran out and I started taking damage. So I changed my tanks and now I take damage when it mines again without a hopper attached, but the minute I attach and then remove a hopper from the bottom of the Astro Base the damage stops.

Now I'm even more confused than before because its now hit or miss. Sometimes it does it sometimes it doesn't and even know I am able to have a hopper connected to the bottom, but when I just removed it instant damage. How a hopper plays into this whole thing I have no idea, but nothing is consistent anymore accept that the hopper is somehow involved.

*Edit - Just tried a cyclic extraction cable attached to the bottom of the base and it does the same thing. Add it damage, remove it no damage.

**Unrelated, but the miner is getting blocked by Volatile Flares(illumination from astral illumination wand) and the coordinates that the base gave were incorrect. I had to go on a hunt to find the miner.
 
Last edited:

radfast

Administrator
Staff member
Apr 27, 2014
1,142
353
83
How a hopper plays into this whole thing I have no idea

Same, no idea. There is literally no connection between a hopper or items in the AstroMiner Base and anything in our mod which can cause player damage. Please can you test the same setup for me with only Galacticraft installed?

It's possible that one of the other mods in the SevTech pack is causing this weird interaction. Maybe you can figure out which one by starting with only Galacticraft installed and then adding SevTech mods in groups until the problem occurs?

-------

Unrelated, but the miner is getting blocked by Volatile Flares(illumination from astral illumination wand)

Thanks we can probably fix that in a future build.

the coordinates that the base gave were incorrect

Are you sure? The coordinates are relative - they are the delta (the distance away from the base).