Decompressor not working... + I don't understand how to handle the liquid tank with oxygen in it...

Discussion in 'Support' started by FreezeeHD, Jun 18, 2017.

  1. FreezeeHD

    FreezeeHD Member

    Joined:
    Jun 18, 2017
    Messages:
    4
    Likes Received:
    0
    Hey, I have 2 questions?

    1st question is: When I place a power line or a liquid line, they don't connect with the decompressor how you can see in the picture... so yeah... i actually can't use it because I can't use the output... Do you see?


    And my 2nd question is: Why is my liquid tank which is made of glass crashing Minecraft? It's crashing Minecraft when I destroy it when it has oxygen in it... I don't know why? Am I doing something wrong? And finally... how can I remove the oxygen out of the tank?

    Thanks for your answers :D NEW.jpg
     
  2. Ezer'Arch

    Ezer'Arch Administrator
    Staff Member

    Joined:
    May 18, 2013
    Messages:
    1,487
    Likes Received:
    412
    Did you use the shift-wrench to individually rotate the faces?
     
  3. radfast

    radfast Administrator
    Staff Member

    Joined:
    Apr 27, 2014
    Messages:
    1,071
    Likes Received:
    330
    Q1: The Decompressor block has its textures on the wrong faces in Galacticraft versions 108 and prior.
    For now you need to connect the wires and pipes to the faces which have the decompressor machine texture.
    This will be fixed in next build 109.

    Q2: Please upload the crash report or cut and paste here the top ~25 lines from it, we cannot help without it
     
  4. FreezeeHD

    FreezeeHD Member

    Joined:
    Jun 18, 2017
    Messages:
    4
    Likes Received:
    0
    Yes I did
     
  5. FreezeeHD

    FreezeeHD Member

    Joined:
    Jun 18, 2017
    Messages:
    4
    Likes Received:
    0
    Here's the Crash-Report :D :


    ---- Minecraft Crash Report ----

    WARNING: coremods are present:
    MicdoodlePlugin (MicdoodleCore-1.8.9-4.0.0.107.jar)
    Contact their authors BEFORE contacting forge

    // I let you down. Sorry :(

    Time: 24.06.17 17:49
    Description: Exception in server tick loop

    java.lang.NullPointerException: Exception in server tick loop
    at micdoodle8.mods.galacticraft.core.tick.TickHandlerServer.onWorldTick(TickHandlerServer.java:546)
    at net.minecraftforge.fml.common.eventhandler.ASMEventHandler_96_TickHandlerServer_onWorldTick_WorldTickEvent.invoke(.dynamic)
    at net.minecraftforge.fml.common.eventhandler.ASMEventHandler.invoke(ASMEventHandler.java:49)
    at net.minecraftforge.fml.common.eventhandler.EventBus.post(EventBus.java:140)
    at net.minecraftforge.fml.common.FMLCommonHandler.onPreWorldTick(FMLCommonHandler.java:274)
    at net.minecraft.server.MinecraftServer.func_71190_q(MinecraftServer.java:686)
    at net.minecraft.server.MinecraftServer.func_71217_p(MinecraftServer.java:605)
    at net.minecraft.server.integrated.IntegratedServer.func_71217_p(IntegratedServer.java:251)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:481)
    at java.lang.Thread.run(Thread.java:745)


    A detailed walkthrough of the error, its code path and all known details is as follows:
    ---------------------------------------------------------------------------------------

    -- System Details --
    Details:
    Minecraft Version: 1.8.9
    Operating System: Windows 10 (amd64) version 10.0
    CPU: 4x Intel(R) Core(TM) i5-7600K CPU @ 3.80GHz
    Java Version: 1.8.0_25, Oracle Corporation
    Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation
    Memory: 286317160 bytes (273 MB) / 1060372480 bytes (1011 MB) up to 1060372480 bytes (1011 MB)
    JVM Flags: 6 total; -XX:HeapDumpPath=MojangTricksIntelDriversForPerformance_javaw.exe_minecraft.exe.heapdump -Xmx1G -XX:+UseConcMarkSweepGC -XX:+CMSIncrementalMode -XX:-UseAdaptiveSizePolicy -Xmn128M
    IntCache: cache: 0, tcache: 0, allocated: 12, tallocated: 94
    FML: MCP 9.19 Powered by Forge 11.15.1.2318 Optifine OptiFine_1.8.9_HD_U_H8 7 mods loaded, 7 mods active
    States: 'U' = Unloaded 'L' = Loaded 'C' = Constructed 'H' = Pre-initialized 'I' = Initialized 'J' = Post-initialized 'A' = Available 'D' = Disabled 'E' = Errored
    UCHIJAAAA mcp{9.19} [Minecraft Coder Pack] (minecraft.jar)
    UCHIJAAAA FML{8.0.99.99} [Forge Mod Loader] (forge-1.8.9-11.15.1.2318-1.8.9.jar)
    UCHIJAAAA Forge{11.15.1.2318} [Minecraft Forge] (forge-1.8.9-11.15.1.2318-1.8.9.jar)
    UCHIJAAAA Micdoodlecore{} [Micdoodle8 Core] (minecraft.jar)
    UCHIJAAAA GalacticraftCore{4.0.0} [Galacticraft Core] (GalacticraftCore-1.8.9-4.0.0.107.jar)
    UCHIJAAAA GalacticraftPlanets{4.0.0} [Galacticraft Planets] (Galacticraft-Planets-1.8.9-4.0.0.107.jar)
    UCHIJAAAA JEI{2.28.18.187} [Just Enough Items] (jei_1.8.9-2.28.18.187.jar)
    Loaded coremods (and transformers):
    MicdoodlePlugin (MicdoodleCore-1.8.9-4.0.0.107.jar)
    micdoodle8.mods.miccore.MicdoodleTransformer
    GL info: ~~ERROR~~ RuntimeException: No OpenGL context found in the current thread.
    Profiler Position: N/A (disabled)
    Player Count: 1 / 8; [GCEntityPlayerMP['FreezeeHD'/279, l='Neue Welttfqwedfa', x=130.78, y=77.00, z=231.65]]
    Type: Integrated Server (map_client.txt)
    Is Modded: Definitely; Client brand changed to 'fml,forge'
    OptiFine Version: OptiFine_1.8.9_HD_U_H8
    Render Distance Chunks: 10
    Mipmaps: 4
    Anisotropic Filtering: 1
    Antialiasing: 0
    Multitexture: false
    Shaders: null
    OpenGlVersion: 4.5.0 NVIDIA 382.33
    OpenGlRenderer: GeForce GTX 1070/PCIe/SSE2
    OpenGlVendor: NVIDIA Corporation
    CpuCount: 4
     
  6. radfast

    radfast Administrator
    Staff Member

    Joined:
    Apr 27, 2014
    Messages:
    1,071
    Likes Received:
    330
    thanks for the crash report, this will be fixed next build (410)
     
  7. FreezeeHD

    FreezeeHD Member

    Joined:
    Jun 18, 2017
    Messages:
    4
    Likes Received:
    0
    It's actually not crashing just when there's oxygen in it, it's crashing with all gases ;D:D thx :D
     

Share This Page