FTB Monster crash when arriving at moon/mars

Discussion in 'Support' started by danielcb114, Dec 30, 2013.

  1. geegee

    geegee Member

    Joined:
    Jan 26, 2014
    Messages:
    35
    Likes Received:
    9
    Can be 1 is enough to control the entire airlock.
     
  2. geegee

    geegee Member

    Joined:
    Jan 26, 2014
    Messages:
    35
    Likes Received:
    9
    hmm funny i started my server and tried to use the airlock. And indeed it crashes.


    Edit:

    I am updating the galacticraft version on my server to see if the issue is already fixed in another build.

    The airlock crash is caused by a bug in galacticraft 2.0.8.908 and is fixed in later versions.
    Tested it with 2.0.9.956 and seems to run smooth.
     
    #62 geegee, Feb 13, 2014
    Last edited: Feb 13, 2014
  3. TheWhiteTyger

    TheWhiteTyger Member

    Joined:
    Jan 28, 2014
    Messages:
    91
    Likes Received:
    4
    That's the version we have! Gonna update now and post results, shouldn't be any except a happy admin! I do thank you for this info!


    EDIT: Wait a tick, I tried to download a new copy from this web site and it gives me the same buggy version. Where can I go to download this new version of Galacticraft?
     
  4. geegee

    geegee Member

    Joined:
    Jan 26, 2014
    Messages:
    35
    Likes Received:
    9
  5. TheWhiteTyger

    TheWhiteTyger Member

    Joined:
    Jan 28, 2014
    Messages:
    91
    Likes Received:
    4
    For a new member, you sure have a LOT of detailed info. *Suspicious suspicious* But hell, I ain't gonna complain I just can't wait to not have to reboot the server 15 times a day!

    Thanks again!!

    BTW since i'm still somewhat of an idiot when it comes to modding, does the new config changes mean that we should delete the config files and let the mod regenrate them and then shut down server and re-edit the config files?
     
  6. geegee

    geegee Member

    Joined:
    Jan 26, 2014
    Messages:
    35
    Likes Received:
    9
    Haha am just your all round nerd :).


    I made some configs added to this post. Silicon ore gen is in there as well.

    Mostly when you update mod versions you should backup your current configs and let the mod generate new once. Then match the new once against the old once because things can be removed or added and can cause bugs or crashes.

    Please read the readme aswell
     

    Attached Files:

  7. TheWhiteTyger

    TheWhiteTyger Member

    Joined:
    Jan 28, 2014
    Messages:
    91
    Likes Received:
    4
    That's exactly what I did since i figured i would have id mismatches and already changed them and restarting server. If it doesn't work with what I have done, I will backup and give your configs a try. Thanks again for all of your help and insight!
     
  8. geegee

    geegee Member

    Joined:
    Jan 26, 2014
    Messages:
    35
    Likes Received:
    9
    No problem :) I hope your issues are fixed now
     
  9. TheWhiteTyger

    TheWhiteTyger Member

    Joined:
    Jan 28, 2014
    Messages:
    91
    Likes Received:
    4
    OK, after hours of fighting with various "things", I somehow managed to get the server up and not crash. Did read readme file, but said option was already disabled. Anywho, the stars aligned and the planets shifted and we got our server up and running without one crash resulting from the moon, finally!!!

    Dude, Why isn't this version out on the home page of the web site? this all started because we got a version that had a known bug in it, now by NO means am I judging or telling anyone what to do, but I wonder how many people are finding the same frustration that we were and having given up on making galacticraft to work miss out on a LOT of game time fun.

    Once more, i can NOT stress enough how much you mean to 10+ people right now. Thank you so very much for just responding to me and sharing your knowledge. I hope one day I can return the favor to you!


    EDIT: No news to report! It seems that was the whole issue and we haven't crashed since we have upgraded. Thank you again!


    UPDATE: Grrr always something... now this is the one time it crashed on us, so the crashes are less frequent, but still exsist. Here is a pastie...

    http://pastebin.com/VJ5EjXy1

    I'm not expecting for every problem to be fixed by you, just if you happen to have an idea, guidance is always appreciated. Still thanks again for the help you did give!
     
    #69 TheWhiteTyger, Feb 13, 2014
    Last edited: Feb 14, 2014
  10. geegee

    geegee Member

    Joined:
    Jan 26, 2014
    Messages:
    35
    Likes Received:
    9
    try this version it appears the crash is fixed in this one.

    http://ci.micdoodle8.com/job/Galacticraft/958/artifact/


    And the reason its not on the homepage as you discovered yourself is because its not yet stable. These are beta versions ;).

    Though I agree that the airlock crash should have been fixed in a minor update.
     
    TheWhiteTyger likes this.
  11. TheWhiteTyger

    TheWhiteTyger Member

    Joined:
    Jan 28, 2014
    Messages:
    91
    Likes Received:
    4
    Not to ever look a gift horse in the mouth, but how do you happen to gain access to these builds? Am I missing something on this site? sorry for the derpy questions, but I did try to find it on the site.

    Anyways, gonna update tomorrow, we are all still on Monster 1.0.7 and I just need to upgrade us to 1.0.9 and THEN implement this fix. (Was hoping to stabilize Galacticraft first, but updates updates updates!)

    Once more, your invaluable input is greatly appreciated!
     
  12. geegee

    geegee Member

    Joined:
    Jan 26, 2014
    Messages:
    35
    Likes Received:
    9
    hehe on the forum right under the support forum there is a link called 'Dev Builds'. Click that and you'll see all the dev / beta builds
     
    TheWhiteTyger likes this.
  13. TheWhiteTyger

    TheWhiteTyger Member

    Joined:
    Jan 28, 2014
    Messages:
    91
    Likes Received:
    4
    UPDATE: Haven't had a crash yet, however with having regen-ning the moon three times, our builder hasn't gotten so far as to try to seal a dungeon yet but finally I am not tearing my hair out hearing "Server Crashed" about every two to three hours at a time.

    Now to upgrade server to 1.0.10 from 1.0.7 cuz yeah this took up a lot of research time. But GeeGee, thank you so much for all of your help! We wouldn't have a working server with galacticraft in it and my players all happy with out your awesome patience and guidance. Honestly, if it wasn't for you, I do believe that either we would have removed Galacticraft, or I was damn close to rage formatting the damn server just because. Thanks for S.O.S (S.aving O.ur S.ever)
     
  14. geegee

    geegee Member

    Joined:
    Jan 26, 2014
    Messages:
    35
    Likes Received:
    9
    No problem :), and good to hear it runs without crashes and I hope for you it keeps running smooth :)
     
    TheWhiteTyger likes this.
  15. TheWhiteTyger

    TheWhiteTyger Member

    Joined:
    Jan 28, 2014
    Messages:
    91
    Likes Received:
    4
    Was hoping this would be the end of troubles, but hey at least everything seems more stable than before. If you, geegee or anyone else might have time to take a look at this one, I would appreciate it very much. :)

    Code:
    Description: Exception in server tick loop
    
    java.lang.ArrayIndexOutOfBoundsException: 15
       at java.util.ArrayList.clear(ArrayList.java:511)
       at micdoodle8.mods.galacticraft.core.tick.GCCoreTickHandlerServer.tickStart(GCCoreTickHandlerServer.java:64)
       at cpw.mods.fml.common.SingleIntervalHandler.tickStart(SingleIntervalHandler.java:28)
       at cpw.mods.fml.common.FMLCommonHandler.tickStart(FMLCommonHandler.java:122)
       at cpw.mods.fml.common.FMLCommonHandler.onPreWorldTick(FMLCommonHandler.java:295)
       at net.minecraft.server.MinecraftServer.func_71190_q(MinecraftServer.java:652)
       at net.minecraft.server.dedicated.DedicatedServer.func_71190_q(DedicatedServer.java:276)
       at net.minecraft.server.MinecraftServer.func_71217_p(MinecraftServer.java:587)
       at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:484)
       at net.minecraft.server.ThreadMinecraftServer.run(SourceFile:583)
    Full pastie here---> http://pastebin.com/Qi48AB4Z

    and here is one from the night before apparently...

    Code:
    ---- Minecraft Crash Report ----
    // This doesn't make any sense!
    
    (You got that right!)
    
    Time: 2/16/14 8:44 PM
    Description: Ticking tile entity
    
    java.lang.IllegalThreadStateException
       at java.lang.Thread.start(Thread.java:684)
       at micdoodle8.mods.galacticraft.core.oxygen.OxygenPressureProtocol.updateSealerStatus(OxygenPressureProtocol.java:132)
       at micdoodle8.mods.galacticraft.core.tile.GCCoreTileEntityOxygenSealer.func_70316_g(GCCoreTileEntityOxygenSealer.java:88)
       at net.minecraft.world.World.func_72939_s(World.java:2209)
       at net.minecraft.world.WorldServer.func_72939_s(WorldServer.java:550)
       at net.minecraft.server.MinecraftServer.func_71190_q(MinecraftServer.java:668)
       at net.minecraft.server.dedicated.DedicatedServer.func_71190_q(DedicatedServer.java:276)
       at net.minecraft.server.MinecraftServer.func_71217_p(MinecraftServer.java:587)
       at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:484)
       at net.minecraft.server.ThreadMinecraftServer.run(SourceFile:583)
    Pastie of this one is on the same pastie as previous one, just below.
     
  16. geegee

    geegee Member

    Joined:
    Jan 26, 2014
    Messages:
    35
    Likes Received:
    9
    Hmm these look like bugs in the dev build sadly. Atleast for the first one.

    I would suggest to report that one in the bugs forum and / or here https://github.com/micdoodle8/Galacticraft/issues (you'll need an account for that site though)

    The second one is something with an airlock. May I ask how it is setup? And what are the possible steps to reproduce it.
     
  17. TheWhiteTyger

    TheWhiteTyger Member

    Joined:
    Jan 28, 2014
    Messages:
    91
    Likes Received:
    4
    Re-tracing what "pops" told me as far as the second listed crash, and going through each airlock in the dungeon (multiple ones due to attempting to seal the whole dungeon and we are still learning and not sure how many to make, so we have two per corner hallway basically) and it seems he had set them up in creative I can only assume because when I click on various airlocks controllers, they usually say "pop's Airlock Controller" but many said " 's Airlock Controller" instead. Sometimes even when I put down the controllers it came up with " 's Airlock Controller" also and I know I was in survival mode.

    The first crash report I shall report to the bug forum here, though I have a strange feeling that it might be seen sooner at the second bug forum. As usual thanks just don't seem enough for what you helped us with.
     
  18. geegee

    geegee Member

    Joined:
    Jan 26, 2014
    Messages:
    35
    Likes Received:
    9
    Hmm you could try to remove all of the airlock blocks and not only the controller that have the no name issue and replace them in survival mode. Maybe that fixes it. You should also report this in the bug's section sinds this is clearly a bug when blocks are placed in creative mode.

    I'll test it out aswell when I get home

    Edit: Does that pop guy see his name on the controllers where you dont see names?
    Cause am placing controllers on the moon like a mad man in creative but they all seem to keep my name.

    Did it happen by any chance after a server reboot?

    Edit 2: I rebooted my server and indeed the username got removed. when controllers are placed in creative

    Edit 3: Placed a controller in survival mode and after a server reboot the name got removed as well. I cannot get it to crash though
     
    #78 geegee, Feb 18, 2014
    Last edited: Feb 18, 2014
  19. TheWhiteTyger

    TheWhiteTyger Member

    Joined:
    Jan 28, 2014
    Messages:
    91
    Likes Received:
    4
    He is also using two controllers that have different settings. I am going through and finding out that he sets airlock controllers incorrectly, even though they work then he fusses at me for changing and fixing them the way they should be. So if you want to recreate the crash, it's best to just set random settings that still work, but would go "beyond necessary needed settings" i.e. "Opens with redstone signal=true", "player is within: 5 meters" even though there is a second controller on the same door and the door is maybe 1x2 opening for example. (and yes it HAS happend as such.)

    So I'm starting to think that the error is ID10T (meaning user failure of course u knew but not everyone else) and it did crash today, but I have been pre-occupied with re-locating and haven't had the time to sit down and fetch logs from the server yet. When I can I will post and I promise I will report this bug properly when I have another 10 mins to sit down.
     
    #79 TheWhiteTyger, Feb 18, 2014
    Last edited: Feb 19, 2014
  20. geegee

    geegee Member

    Joined:
    Jan 26, 2014
    Messages:
    35
    Likes Received:
    9
    TheWhiteTyger likes this.

Share This Page