Galacticraft 3 Release Notes

Discussion in 'General' started by micdoodle8, Jul 25, 2014.

  1. ShadowWarrior979

    Joined:
    Aug 8, 2013
    Messages:
    69
    Likes Received:
    0
    I am still having the problem with the space stations in the new BETA, i press create space station and then click the earth and then the spinning icon and the launch button is green but does not work
     
  2. LividPumpkin

    LividPumpkin Member

    Joined:
    Nov 8, 2013
    Messages:
    73
    Likes Received:
    1
    Me 2 tried to press Enter button but the game crashed
     
  3. Douglas_Fresh

    Douglas_Fresh Member

    Joined:
    Sep 17, 2013
    Messages:
    804
    Likes Received:
    245
    They're still working on fixing that.
     
  4. ShadowWarrior979

    Joined:
    Aug 8, 2013
    Messages:
    69
    Likes Received:
    0
    Oh are they? sorry i read that they had fixed the bug in the latest Beta so assumed it was all systems go
     
    #64 ShadowWarrior979, Jul 27, 2014
    Last edited: Jul 27, 2014
  5. radfast

    radfast Administrator
    Staff Member

    Joined:
    Apr 27, 2014
    Messages:
    1,143
    Likes Received:
    352
    @ShadowWarrior979 Space station launch works for me since build 3.0.0.122.

    Some people are still having problems with the launch, but we haven't yet figured out why. Could be a bug, could be something weird to do with different player names (for example names with numbers in) or maybe small differences in the way that different people click on things, really I don't know right now. It's hard to troubleshoot issues I'm not experiencing when I play.

    Anyone still having problems, please use the latest build 3.0.0.124, get it from here: http://ci.micdoodle8.com/job/Galacticraft-1.7/124/
    * if you're seeing problems, try exit Minecraft completely, restart, and create a new world
    * change the debug setting to "true" in .minecraft/config/Galacticraft/core.conf
    * post relevant parts of your log or console - there will be some console spam in debug mode, we don't need to see all of it just an example
    * check the latest situation on this issue report thread: https://github.com/micdoodle8/Galacticraft/issues/609
     
  6. MCcraftingCz

    MCcraftingCz Member

    Joined:
    Feb 22, 2014
    Messages:
    38
    Likes Received:
    3
    If I get fall damage, the game has crashed. Do you have the same problem?
     
  7. ShadowWarrior979

    Joined:
    Aug 8, 2013
    Messages:
    69
    Likes Received:
    0
    Ok rad maybe its me tell me if i do this wrong i click overworld and then press create space station, then i click on the overworld icon and zoom in. Then i click the satellite icon and click launch but nothing happens... am i doing it wrong
     
  8. S_Hacker

    S_Hacker Member

    Joined:
    Jan 19, 2014
    Messages:
    88
    Likes Received:
    5
    It's not the final version and more things will be added? I guess we will have to wait a little longer for more places like jupiter or it's moons or maybe venus.
     
  9. Douglas_Fresh

    Douglas_Fresh Member

    Joined:
    Sep 17, 2013
    Messages:
    804
    Likes Received:
    245
    Are you using build version #122 or higher? The first beta release had that issue unless you were wearing a full set of armor. The newer version (build 122) fixed that.

    There was an issue with players' names that had capital letters (like mine) that has been resolved with build #126. Works fine for me now.
    http://ci.micdoodle8.com/job/Galacticraft-1.7/126/

    Galacticraft has quite a long future ahead by the looks of it (and that is a great thing). It will probably be quite a while before another dimension is added after the Asteroids.
     
    radfast and SirKillz like this.
  10. Douglas_Fresh

    Douglas_Fresh Member

    Joined:
    Sep 17, 2013
    Messages:
    804
    Likes Received:
    245
    I've noticed that every air lock frame does it consistently. It depends on how you look at it. Every side facing either north or east has the lights pointing one direction and every side facing either south or west faces the opposite. So if an air lock has the lights facing outward, walk through it and look from the other side and they are pointing inward.

    EDIT: To help make sure everything is clear, picture 1 is facing north and I crossed the room and turned around facing south for picture 2

    2014-07-27_10.43.39.png

    2014-07-27_10.43.39.png
     

    Attached Files:

    #70 Douglas_Fresh, Jul 27, 2014
    Last edited: Jul 27, 2014
  11. ShadowWarrior979

    Joined:
    Aug 8, 2013
    Messages:
    69
    Likes Received:
    0
    i have downloaded a friends station and am trying to use it but i get
    [04:27:10 INFO]: Client> [04:27:10] [Client thread/ERROR] [Galacticraft]: Problem matching player name in space station check: shadowwarrior979
    is there away i can swap his name out and put my name in so i can use the station?
     
  12. radfast

    radfast Administrator
    Staff Member

    Joined:
    Apr 27, 2014
    Messages:
    1,143
    Likes Received:
    352
    @ShadowWarrior979, it looks like that's a similar name matching issue with the capital letters. We'll fix that later today and I'll do a check for any other possible places where the same issue might crop up.
     
  13. CaptainTurbomuffin

    Joined:
    Aug 26, 2013
    Messages:
    84
    Likes Received:
    8
    Are the things having new IDs?
     
  14. radfast

    radfast Administrator
    Staff Member

    Joined:
    Apr 27, 2014
    Messages:
    1,143
    Likes Received:
    352
    Did you read the release notes?

     
  15. CaptainTurbomuffin

    Joined:
    Aug 26, 2013
    Messages:
    84
    Likes Received:
    8
    Seems like no :rolleyes:
     
  16. ShadowWarrior979

    Joined:
    Aug 8, 2013
    Messages:
    69
    Likes Received:
    0
    @radfast I can access the station if he gives me his world and i spawn in the station but i cannot access it from the map like normal.
     
  17. PureTryOut

    PureTryOut Member

    Joined:
    Mar 5, 2013
    Messages:
    215
    Likes Received:
    19
    I can actually not play the BETA release at all...
    Using Ubuntu 14.04 x86_64 with Oracle Java 8 update 11 x64 I get the following error:
    Code:
    java.lang.RuntimeException: BAD GALACTICRAFT/MICDOODLECORE SETUP null null
        at micdoodle8.mods.miccore.MicdoodlePlugin.injectData(MicdoodlePlugin.java:195) ~[MicdoodlePlugin.class:?]
        at cpw.mods.fml.relauncher.CoreModManager$FMLPluginWrapper.injectIntoClassLoader(CoreModManager.java:113) ~[forge-1.7.2-10.12.2.1147.jar:?]
        at net.minecraft.launchwrapper.Launch.launch(Launch.java:114) [launchwrapper-1.9.jar:?]
        at net.minecraft.launchwrapper.Launch.main(Launch.java:28) [launchwrapper-1.9.jar:?]
    
     
  18. radfast

    radfast Administrator
    Staff Member

    Joined:
    Apr 27, 2014
    Messages:
    1,143
    Likes Received:
    352
    @PureTryOut:
    * It's a simple filename check that you have exactly matching versions of GalacticraftCore and MicdoodleCore in your /mods folder.
    * If you're using subfolders in the /mods folder, that is not handled yet (will be soon)
    * If you can't fix it with this information, could be that it's due to some unexpected difference in the way Ubuntu or Java 8 handles filenames, we build in Java 7.
     
  19. PureTryOut

    PureTryOut Member

    Joined:
    Mar 5, 2013
    Messages:
    215
    Likes Received:
    19
    Well I don't work with subfolders, which I didn't even know was possible...
    I've tried OpenJDK 7 too but it gives me the exact same error. I'll try Oracle Java 7 too though.

    EDIT: Tried Oracle Java 7 (too make it clear, this is the same Java as everyone uses on Windows but then for Linux), but I have the same error.
    I guess it's a general Linux thing? Can this be fixed?

    For reference the full log:
    Code:
    [19:04:14] [main/INFO] [LaunchWrapper]: Loading tweak class name cpw.mods.fml.common.launcher.FMLTweaker
    [19:04:14] [main/INFO] [LaunchWrapper]: Using primary tweak class name cpw.mods.fml.common.launcher.FMLTweaker
    [19:04:14] [main/INFO] [LaunchWrapper]: Calling tweak class cpw.mods.fml.common.launcher.FMLTweaker
    [19:04:14] [main/INFO] [FML]: Forge Mod Loader version 7.2.217.1147 for Minecraft 1.7.2 loading
    [19:04:14] [main/INFO] [FML]: Java is Java HotSpot(TM) 64-Bit Server VM, version 1.7.0_65, running on Linux:amd64:3.13.0-32-generic, installed at /usr/lib/jvm/java-7-oracle/jre
    [19:04:14] [main/WARN] [FML]: The coremod micdoodle8.mods.miccore.MicdoodlePlugin does not have a MCVersion annotation, it may cause issues with this version of Minecraft
    [19:04:14] [main/INFO] [FML]: Loading tweaker optifine.OptiFineForgeTweaker from OptiFine HD U D1.jar
    [19:04:14] [main/INFO] [FML]: Loading tweaker shadersmodcore.loading.SMCTweaker from ShadersModCore v2.3.9.jar
    [19:04:14] [main/INFO] [LaunchWrapper]: Loading tweak class name cpw.mods.fml.common.launcher.FMLInjectionAndSortingTweaker
    [19:04:14] [main/INFO] [LaunchWrapper]: Loading tweak class name optifine.OptiFineForgeTweaker
    [19:04:14] [main/INFO] [LaunchWrapper]: Loading tweak class name shadersmodcore.loading.SMCTweaker
    [19:04:14] [main/INFO] [LaunchWrapper]: Loading tweak class name cpw.mods.fml.common.launcher.FMLDeobfTweaker
    [19:04:14] [main/INFO] [LaunchWrapper]: Calling tweak class cpw.mods.fml.common.launcher.FMLInjectionAndSortingTweaker
    [19:04:14] [main/INFO] [LaunchWrapper]: Calling tweak class cpw.mods.fml.common.launcher.FMLInjectionAndSortingTweaker
    [19:04:14] [main/INFO] [LaunchWrapper]: Calling tweak class optifine.OptiFineForgeTweaker
    OptiFineForgeTweaker: acceptOptions
    OptiFineForgeTweaker: injectIntoClassLoader
    OptiFine ClassTransformer
    OptiFine URL: file:/home/bart/.minecraft/instances/mods1.7.2/mods/OptiFine%20HD%20U%20D1.jar
    OptiFine ZIP file: [email protected]
    [19:04:14] [main/INFO] [LaunchWrapper]: Calling tweak class cpw.mods.fml.relauncher.CoreModManager$FMLPluginWrapper
    [19:04:16] [main/INFO] [FML]: Found valid fingerprint for Minecraft Forge. Certificate fingerprint e3c3d50c7c986df74c645c0ac54639741c90a557
    [19:04:16] [main/INFO] [FML]: Found valid fingerprint for Minecraft. Certificate fingerprint cd99959656f753dc28d863b46769f7f8fbaefcfc
    [19:04:16] [main/INFO] [LaunchWrapper]: Calling tweak class cpw.mods.fml.relauncher.CoreModManager$FMLPluginWrapper
    [19:04:16] [main/INFO] [LaunchWrapper]: Calling tweak class cpw.mods.fml.relauncher.CoreModManager$FMLPluginWrapper
    Successfully Registered Transformer
    [19:04:16] [main/ERROR] [LaunchWrapper]: Unable to launch
    java.lang.RuntimeException: BAD GALACTICRAFT/MICDOODLECORE SETUP null null
        at micdoodle8.mods.miccore.MicdoodlePlugin.injectData(MicdoodlePlugin.java:195) ~[MicdoodlePlugin.class:?]
        at cpw.mods.fml.relauncher.CoreModManager$FMLPluginWrapper.injectIntoClassLoader(CoreModManager.java:113) ~[forge-1.7.2-10.12.2.1147.jar:?]
        at net.minecraft.launchwrapper.Launch.launch(Launch.java:114) [launchwrapper-1.9.jar:?]
        at net.minecraft.launchwrapper.Launch.main(Launch.java:28) [launchwrapper-1.9.jar:?]
    Removing Optifine and the Shadersmod didn't fix anything either...
     
    #79 PureTryOut, Jul 29, 2014
    Last edited: Jul 29, 2014
  20. radfast

    radfast Administrator
    Staff Member

    Joined:
    Apr 27, 2014
    Messages:
    1,143
    Likes Received:
    352
    @PureTryOut if you're still seeing this problem, try the latest version 136 of GC3 beta. It will give you the choice of 'ignoring' the bad setup and continuing, instead of crashing out like that. I cannot tell why it thinks your setup is bad without sitting at your computer, but anyhow version 136 should let you get past this.
     

Share This Page