Apr 5, 2015
Minecraft Version = 1.6.4

Forge Version =

Galacticraft Version = 1.7-

Detailed Description = When I launch Galacticraft on my computer and run a server with the specified version of Forge, everything seems to work as it should. But when there is more than 1 player in game, and one player is to launch the space rocket to another planet, the game crashes. Either we all get the Timed out error on our screens or another similar error, and it ALWAYS happens when the rocket launches into space to go to another planet, while the other planet is loading. Also it lags for the player (not riding the rocket) while it's airborn.

I tried removing other mods such as Smart moving etc. until Galacticraft was the only mod running alongside the 4Space addon, and we still got the same issue.
We have tried running on several different computers running the same version of Forge and Galacticraft, and it makes no difference whatsoever.

We have tried using a few different versions of Forge (not many, but a few) and that did not work.
Both Galacticraft and Forge are running properly and is properly installed in the server directory.
What we haven't tried is removing 4Space, but since it's an addon made for this mod, I highly doubt it would make any difference.

DO NOT mistake me, I posted this to HELP Galacticraft and it's creator to resolve this issue, NOT to complain about this perfected and truly beautiful mod.

Full Forge Log =