Galacticraft doesnt work on my modded server

Discussion in 'Support' started by RedRain96, Dec 2, 2014.

  1. RedRain96

    RedRain96 Member

    Joined:
    Oct 18, 2014
    Messages:
    17
    Likes Received:
    0
    Hi! I opend a minecraft server version 1.7.10 and I installed in it NEI and Damage indicators.
    At the Singleplayer the Mod is working but in the server it says the mod doesn`t work.
    Any suggestions? I viewed videos how to install and I did exactly the same thing and still don`t work..

    [​IMG]


    [​IMG]
     
    #1 RedRain96, Dec 2, 2014
    Last edited: Dec 2, 2014
  2. radfast

    radfast Administrator
    Staff Member

    Joined:
    Apr 27, 2014
    Messages:
    1,144
    Likes Received:
    352
    Please explain more what you mean by "doesn't work"?

    Please post your fml-server-latest.log in full.

    We regularly test Galacticraft on servers with a variety of other mods.

    One more thing, you should use the latest 3.0.6.239, it's better than 3.0.6.232 - fixed a few things, including a crash with the latest version of Buildcraft.
     
  3. RedRain96

    RedRain96 Member

    Joined:
    Oct 18, 2014
    Messages:
    17
    Likes Received:
    0
    Umm Ok, When I mean doesn't work I mean that the mod does not exist on my server, even that I'v putted the jars in the mods folder of the server.

    I found this quote in the Log: [19:43:21] [main/WARN] [FML/]: The coremod micdoodle8.mods.miccore.MicdoodlePlugin does not have a MCVersion annotation, it may cause issues with this version of Minecraft

    I can't send the full log, over 1000 chars..
     
  4. radfast

    radfast Administrator
    Staff Member

    Joined:
    Apr 27, 2014
    Messages:
    1,144
    Likes Received:
    352
    That won't cause any problems. Most mods do not have a MCVersion annotation.

    If the three Galacticraft .jar files are in the /mods folder on server then Galacticraft must load. Your screenshot looks OK - I guess that is from the Minecraft folder which your server is running in?

    Find a way to post the log file, then maybe we can help you properly. You can use Pastebin, Dropbox or any cloud service, just post up the link.
     
  5. RedRain96

    RedRain96 Member

    Joined:
    Oct 18, 2014
    Messages:
    17
    Likes Received:
    0
    Yea, Its from the folder which my server is running.
    Any ways, I'v uploaded the latest log to Mediafire:

    https://www.mediafire.com/?nrfmex2ez87wjna
     
  6. radfast

    radfast Administrator
    Staff Member

    Joined:
    Apr 27, 2014
    Messages:
    1,144
    Likes Received:
    352
    In that log, Galacticraft is working fine, it's your NEI which is not working. That's why your server is not starting!!

    You need CodeChickenCore for NEI to work.

    Also, I'm not totally sure about this, but I think you don't need Damage Indicators on the server - it's only needed on the client.
     
  7. RedRain96

    RedRain96 Member

    Joined:
    Oct 18, 2014
    Messages:
    17
    Likes Received:
    0
    K, I'll check it out, Thank you very much!
    BTW, I forgot to mention that when I put a Galacticraft blocks on the ground it disapper instatly, Even if I take the block from the creative menu

    Edit: Still doesn't working. I'v entered the server and took a block from the menu and It disapperd. Also the NEI says the blocks doesn't exist, And other bloccks such like dirt or stone working via NEI..
     
    #7 RedRain96, Dec 5, 2014
    Last edited: Dec 5, 2014
  8. radfast

    radfast Administrator
    Staff Member

    Joined:
    Apr 27, 2014
    Messages:
    1,144
    Likes Received:
    352
    Still sounds like an NEI problem.
     
  9. RedRain96

    RedRain96 Member

    Joined:
    Oct 18, 2014
    Messages:
    17
    Likes Received:
    0
    I'v removed my NEI from my server and client and tried to press the Oxygen mask when I was on Survival mode it I got this message in chat:
    "For Galacticraft help: wiki.micdoodle8.com/wiki/1 To see this message again at any time, type /gchelp.

    So as I see Galacticraft doesn't work and not because NEI.. I think.
     
  10. radfast

    radfast Administrator
    Staff Member

    Joined:
    Apr 27, 2014
    Messages:
    1,144
    Likes Received:
    352
    That message in chat is normal, shows Galacticraft is working.
     
  11. RedRain96

    RedRain96 Member

    Joined:
    Oct 18, 2014
    Messages:
    17
    Likes Received:
    0
    So why can't I place GC blocks? Galacticraft is on the server but doesn't working? :(
    Mabye I need to use 1.6.x version?
     
  12. radfast

    radfast Administrator
    Staff Member

    Joined:
    Apr 27, 2014
    Messages:
    1,144
    Likes Received:
    352
    Post your full fml-server-server.log please
     
  13. RedRain96

    RedRain96 Member

    Joined:
    Oct 18, 2014
    Messages:
    17
    Likes Received:
    0
    I'v already done that don't I? If not where can I find this log?
     
  14. radfast

    radfast Administrator
    Staff Member

    Joined:
    Apr 27, 2014
    Messages:
    1,144
    Likes Received:
    352
    Buddy I'm trying to help you. Post the newer version of that same log file. The log you already posted stops at the NEI error. I'm assuming your server has moved beyond that by now so there will be more information in a new log...
     
    MoltonMontro likes this.
  15. RedRain96

    RedRain96 Member

    Joined:
    Oct 18, 2014
    Messages:
    17
    Likes Received:
    0
    K, I'v uploaded to Mediafire the latest log:
    https://www.mediafire.com/?nrfmex2ez87wjna
     
  16. radfast

    radfast Administrator
    Staff Member

    Joined:
    Apr 27, 2014
    Messages:
    1,144
    Likes Received:
    352
    I looked at the log. You do not have the three Galacticraft mod files installed on your server.

    On your desktop, I can see you made a folder "Minecraft server".
    * Go to that folder.
    * Open subfolder "mods".
    * Put copies of the three Galacticraft mod files (that's GalacticraftCore, MicdoodleCore and Galacticraft-Planets) in it.
     
  17. RedRain96

    RedRain96 Member

    Joined:
    Oct 18, 2014
    Messages:
    17
    Likes Received:
    0
    I'v already done that dude, I got GalacticraftCore, Planets and micdoodle in the mods folder before I open a topic here.
     
  18. radfast

    radfast Administrator
    Staff Member

    Joined:
    Apr 27, 2014
    Messages:
    1,144
    Likes Received:
    352
    Check again.

    To be totally clear: when you are running a server it runs in whichever folder you placed the server file. In your case, that's a folder on your desktop named "Minecraft Server". It looks for the mods in that folder. Not in .minecraft. You need to make a fresh copy of your /mods folder.
     
  19. RedRain96

    RedRain96 Member

    Joined:
    Oct 18, 2014
    Messages:
    17
    Likes Received:
    0
    I'v copied the folder mods from my .minecraft to my Minecraft server folder and still doesn't work.. Iv transferd my Minecraft server folder to the .minecraft folder...
     
  20. radfast

    radfast Administrator
    Staff Member

    Joined:
    Apr 27, 2014
    Messages:
    1,144
    Likes Received:
    352
    Post up your new fml-server-latest.log please.
     

Share This Page