Galacticraft Not Working On Forge 1.8.9 Server

Discussion in 'Support' started by Oliver5195, Sep 8, 2019.

Tags:
  1. Oliver5195

    Oliver5195 Member

    Joined:
    Sep 7, 2019
    Messages:
    2
    Likes Received:
    0
    This is going to be a long one but please help if you can cause i'm tired of trying to fix this and i don't have a lot of experience in server hosting let alone servers with mods.

    Basically I am running a forge 1.8.9 server on my computer and galacticraft doesn't work.

    Basic information:
    Computer:
    MacBook Pro (17-inch, Early 2011)
    Processor: 2.2 GHz Intel Core i7
    Memory: 16 GB 1333 MHz DDR3
    Graphics: AMD Radeon HD 6750M 1024 MB
    Intel HD Graphics 3000 512 MB

    Running Java 8

    Note that this is MacOS not Windows

    The thing that made me write this thread was that something weird happened (I probably just don't understand what happened) In the beginning when i was starting the server I would click the forge server file thats on the very bottom right of the picture. (Note that at the start there wasn't the start.command file at the beginning)

    Screen Shot 2019-09-07 at 4.35.41 pm.png

    and the server would start up and work fine. Using this method 1gb of ram was automatically allocated to the server. About a week later the server would start up but then after about 30 seconds everyone would get kicked with the message: Timed Out. If you tried joining back the same thing would happen. I checked the crash reports to see what the problem was and it said that the tick speed was too slow and it would shut down assuming the server crashed. I thought that to fix this I should allocate more ram to the server cause we were probably overloading it. (there are about 50 mods on the server and we were using all of them) Thats when i made the start.command file which would start the server with 8gb of ram.

    This is the code in the start.command file:
    #!/bin/sh
    cd "$( dirname "$0" )"
    java -Xmx8192M -Xms8192M -XX:+UseConcMarkSweepGC -jar forge-1.8.9-11.15.1.2318-1.8.9-universal.jar

    This is where the problem began. When starting the server with this file it would start up and crash. Looking through the crash report I saw that the problem was the galacticraft files. This is where it gets confusing. Starting the server with the latest galacticraft files showed that MicdoodleCore was the problem as shown in this screenshot.

    Screen Shot 2019-09-07 at 4.56.36 pm.png

    When I saw this is starting experimenting. I decided that to fix this I just needed a different version of the MicDoodleCore file. After a long time I found that the newest version of the file that would work is MicdoodleCore-1.8.9-4.0.0.17.jar. But when I tried starting the server with this version of Micdoodlecore I would get this message:

    Screen Shot 2019-09-07 at 5.04.12 pm.png

    So I downloaded the same versions of Galacticraft Core and Galacticraft Planets. Also before I continue could someone tell me if these versions have less content than the newer ones and if I will lose a lot of save data thx. Anyways when I downloaded the older versions this happened:

    Screen Shot 2019-09-07 at 5.10.14 pm.png
    Screen Shot 2019-09-07 at 5.10.46 pm.png
    Screen Shot 2019-09-07 at 5.11.17 pm.png
    Note that no other mods had UCE (Errored). They all had UCH (Pre-initialized) next to them.
    So basically I need to use the Old version of Micdoodlecore for it to work but to use the old version I also need the old versions of Galacticraft Core and Galacitcraft planets which don't work when using the old versions.

    Someone please tell me how to fix this without losing any save data.

    Thank you
     

    Attached Files:

  2. QuadShot

    QuadShot Member

    Joined:
    Jun 1, 2015
    Messages:
    202
    Likes Received:
    22
    All of the files MUST be from the same "build" ie have the same version number. Builds/Versions only add functionality and bug fixes. You should not loose anything by updating.
    You should be running the "latest" version, for 1.8.9 it should be 1.8.9-4.0.2.190
    Be sure to grab the files from here: https://micdoodle8.com/mods/galacticraft/downloads
    And make sure that the Extra Planets mod is for this version as well.
    Hope this helps
     
  3. Oliver5195

    Oliver5195 Member

    Joined:
    Sep 7, 2019
    Messages:
    2
    Likes Received:
    0
    In the part where I said "this is where the problem began" i was in fact using the latest versions of all 3 galacticraft files. All the files had the same version. I already documented what happened. It says Unsupported major.minor version 52.0 and it wouldn't start
     

Share This Page