Game crashes when i Put on The sensor glasses

Macindroid

Member
Dec 16, 2013
1
0
1
32
HI i put the sensor glasses on my character and now when ever i open the game it crashes Pleas help!

---- Minecraft Crash Report ----
// Don't do that.

Time: 16/12/13 4:42 PM
Description: Unexpected error

java.lang.ClassCastException: universalelectricity.core.vector.Vector3 cannot be cast to [I
at micdoodle8.mods.galacticraft.core.client.gui.GCCoreOverlaySensorGlasses.renderSensorGlassesValueableBlocks(GCCoreOverlaySensorGlasses.java:78)
at micdoodle8.mods.galacticraft.core.items.GCCoreItemSensorGlasses.renderHelmetOverlay(GCCoreItemSensorGlasses.java:55)
at net.minecraftforge.client.GuiIngameForge.renderHelmet(GuiIngameForge.java:250)
at net.minecraftforge.client.GuiIngameForge.func_73830_a(GuiIngameForge.java:117)
at net.minecraft.client.renderer.EntityRenderer.func_78480_b(EntityRenderer.java:1014)
at net.minecraft.client.Minecraft.func_71411_J(Minecraft.java:946)
at net.minecraft.client.Minecraft.func_99999_d(Minecraft.java:838)
at net.minecraft.client.main.Main.main(SourceFile:101)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at net.minecraft.launchwrapper.Launch.launch(Launch.java:131)
at net.minecraft.launchwrapper.Launch.main(Launch.java:27)
 

Douglas_Fresh

Member
Sep 17, 2013
797
241
63
34
Seattle, WA, USA
www.youtube.com
This is a common issue that I've seen several people having with version 2.0.7 (I'm assuming that's what you're using). This happened to me too. You should be able to revert back to 2.0.6 just to take them off so you don't lose your world. Then you can go back to 2.0.7 as long as you don't use them again or just stay on 2.0.6 like I am for now. You should also submit a bug report:

http://forum.micdoodle8.com/index.php?forms/submit-a-bug-report.1/respond
 

BGF_Yankee

Member
Jan 20, 2014
17
5
3
43
I am having this same problem within the Lapito's Galacticraft pack in FTB on 2.0.7. Is there a way that I can roll back to 2.0.6 within that to give this a try? Are there any other remedies or am I just boned?
 

Douglas_Fresh

Member
Sep 17, 2013
797
241
63
34
Seattle, WA, USA
www.youtube.com
I am having this same problem within the Lapito's Galacticraft pack in FTB on 2.0.7. Is there a way that I can roll back to 2.0.6 within that to give this a try? Are there any other remedies or am I just boned?
I honestly don't know much about mod packs since I just piece together my own mod collection. Hopefully someone else has more information about changing the version within a pack :/
 

BGF_Yankee

Member
Jan 20, 2014
17
5
3
43
It was weird, I put the glasses on outside and had no problem. Then, when I go underground, it just immediately crashes. I can't even restart without it immediately crashing no matter what I seem to try. Thanks though.
 

Douglas_Fresh

Member
Sep 17, 2013
797
241
63
34
Seattle, WA, USA
www.youtube.com
Yeah I think it has to do with the actual detection of ores, not just them being worn. When it happened to me it seemed that it was as soon as I was within range of ores that show up on the HUD. If you can figure out how to update Galacticraft within that mod pack the issue was fixed with 2.0.8 so whether updating or reverting to 2.0.6 it could be fixed. That obviously doesn't solve the issue at the moment though. Perhaps suggest that they update the pack.
 

BGF_Yankee

Member
Jan 20, 2014
17
5
3
43
Thank you for all the info. I was able to force update the mod pack and it allowed me to get back in. I really didn't want to lose all my progress!
 
Feb 12, 2014
2
0
1
39
I also am having the problem where the sensor glasses are crashing my game as soon as it launches! I am running Galacticraft 2.0.7
Yankee, how did you force update the mod?? I cannot even get into my world without it crashing. I am also using the Forge Server application to host my world.
Any help would be much appreciated!!!

---- Minecraft Crash Report ----
// I feel sad now :(

Time: 2/12/14 9:03 PM
Description: Unexpected error

java.lang.ClassCastException: universalelectricity.core.vector.Vector3 cannot be cast to [I
at micdoodle8.mods.galacticraft.core.client.gui.GCCoreOverlaySensorGlasses.renderSensorGlassesValueableBlocks(GCCoreOverlaySensorGlasses.java:78)
at micdoodle8.mods.galacticraft.core.items.GCCoreItemSensorGlasses.renderHelmetOverlay(GCCoreItemSensorGlasses.java:55)
at net.minecraftforge.client.GuiIngameForge.renderHelmet(GuiIngameForge.java:250)
at net.minecraftforge.client.GuiIngameForge.func_73830_a(GuiIngameForge.java:117)
at net.minecraft.client.renderer.EntityRenderer.func_78480_b(EntityRenderer.java:1131)
at net.minecraft.client.Minecraft.func_71411_J(Minecraft.java:946)
at net.minecraft.client.Minecraft.func_99999_d(Minecraft.java:838)
at net.minecraft.client.main.Main.main(SourceFile:101)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at net.minecraft.launchwrapper.Launch.launch(Launch.java:131)
at net.minecraft.launchwrapper.Launch.main(Launch.java:27)
 

BGF_Yankee

Member
Jan 20, 2014
17
5
3
43
First of all, are you playing on a regular copy of Minecraft that you've modded or within a Tekkit or FTB launcher? I was playing the Lapito's Galacticraft Modpack through the FTB launcher. Fortunately, LGM runs on 1.6.4 there, so I was able to remove the 2.0.7 Galacticraft files in favor of the 2.0.8 files. After rebooting, I was able to get back into the game. I've been too scared to try the sensor glasses again since!
 
Feb 12, 2014
2
0
1
39
First of all, are you playing on a regular copy of Minecraft that you've modded or within a Tekkit or FTB launcher? I was playing the Lapito's Galacticraft Modpack through the FTB launcher. Fortunately, LGM runs on 1.6.4 there, so I was able to remove the 2.0.7 Galacticraft files in favor of the 2.0.8 files. After rebooting, I was able to get back into the game. I've been too scared to try the sensor glasses again since!
A regular copy with just Galacticraft and a few other small gun mods. I'm running off of Minecraft 1.6.4. Any advice?
 

BGF_Yankee

Member
Jan 20, 2014
17
5
3
43
Yeah. It should be no trouble at all. Just download the three 2.0.8 Galacticraft mods from this website and replace the 2.0.7 ones in your mod folder for Minecraft. Easy peasy. That's really all I did.