How to make a Galacticraft 1.6.X server

Discussion in 'Support' started by Scott Mackenzie, Jul 18, 2013.

  1. Rastlore

    Rastlore Member

    Joined:
    Aug 2, 2013
    Messages:
    7
    Likes Received:
    0
    Thanks, glad it wasn't something I overlooked in the instructions. :)
     
  2. tihmstar

    tihmstar Member

    Joined:
    Jul 23, 2013
    Messages:
    83
    Likes Received:
    3
    try installing orcacle jre
     
  3. Rastlore

    Rastlore Member

    Joined:
    Aug 2, 2013
    Messages:
    7
    Likes Received:
    0
    Thanks for the assist, but that basically was Java Runtime Environment 7 update 25.... already had it but for kicks I went ahead and re installed it. Still getting the same failure loop.
     
  4. wolfbane3333

    wolfbane3333 Member

    Joined:
    Aug 22, 2013
    Messages:
    13
    Likes Received:
    0
    so i made a server and put MicdoodleCore-1.6.2-a0.1.39.566 and Galacticraft-1.6.2-a0.1.39.566 into the mods folder. i ran the server with the forge jar and it runs great. but when i try to join it with exactly the same files it says that im missing files from galcticraft core, even when i copy the files from the server's mods file and put it in mine.
     
  5. MasterOanarchY

    MasterOanarchY Moderator
    Staff Member

    Joined:
    Jul 3, 2013
    Messages:
    1,016
    Likes Received:
    38
    First could you pastebin.com the ForgeModLoader-client.log, and the ForgeModLoader-server.log. They will be in your Minecraft, and Server folders. Secondly can you create a Single Player Galacticraft game?
     
  6. MasterOanarchY

    MasterOanarchY Moderator
    Staff Member

    Joined:
    Jul 3, 2013
    Messages:
    1,016
    Likes Received:
    38
    I'm sorry Rastlore I lost track of helping you. Did you get it figured out?
     
  7. wolfbane3333

    wolfbane3333 Member

    Joined:
    Aug 22, 2013
    Messages:
    13
    Likes Received:
    0
    sorry, ive never used pastebin.com but it might help if you told me what you wanted like the whole report or something like that
     
  8. MasterOanarchY

    MasterOanarchY Moderator
    Staff Member

    Joined:
    Jul 3, 2013
    Messages:
    1,016
    Likes Received:
    38
  9. wolfbane3333

    wolfbane3333 Member

    Joined:
    Aug 22, 2013
    Messages:
    13
    Likes Received:
    0
  10. MasterOanarchY

    MasterOanarchY Moderator
    Staff Member

    Joined:
    Jul 3, 2013
    Messages:
    1,016
    Likes Received:
    38
    I noticed your using NEI. Did you put in the appropriate JVM arguement to work with NEI? Also NEI requires Forge version 804. You're using 789.
     
  11. MasterOanarchY

    MasterOanarchY Moderator
    Staff Member

    Joined:
    Jul 3, 2013
    Messages:
    1,016
    Likes Received:
    38
    NM you're using 2 different versions of Forge. The server is running 804, and the client is running 789. You need at least 804 for NEI. You also need the JVM argument.
    Also the server is running Galacticraft 566 and Micdoodle 487. You need to fix that as well. Get both client and server to all of the same versions, and see what you get.
     
  12. wolfbane3333

    wolfbane3333 Member

    Joined:
    Aug 22, 2013
    Messages:
    13
    Likes Received:
    0
    alright, i did it but it's still giving me the same message.
     
  13. wolfbane3333

    wolfbane3333 Member

    Joined:
    Aug 22, 2013
    Messages:
    13
    Likes Received:
    0
  14. MasterOanarchY

    MasterOanarchY Moderator
    Staff Member

    Joined:
    Jul 3, 2013
    Messages:
    1,016
    Likes Received:
    38
    According to the first pastebin you're still running the 487 of micdoodle, and the 566 of galacticraft on your server. Please fix that first.
     
  15. wolfbane3333

    wolfbane3333 Member

    Joined:
    Aug 22, 2013
    Messages:
    13
    Likes Received:
    0
    the file says it's 566
     
  16. MasterOanarchY

    MasterOanarchY Moderator
    Staff Member

    Joined:
    Jul 3, 2013
    Messages:
    1,016
    Likes Received:
    38
    2013-08-25 19:07:31 [FINE] [ForgeModLoader] Examining for coremod candidacy Galacticraft-1.6.2-a0.1.39.566.jar
    2013-08-25 19:07:31 [FINE] [ForgeModLoader] Examining for coremod candidacy MicdoodleCore-1.6.2-a0.1.38.487.jar
    Your log says it's not.
    Hmmm ........

    Edit: and here
    2013-08-25 19:07:39 [FINER] [ForgeModLoader] Skipping known library file C:\Documents and Settings\Parent\Desktop\modded server\mods\MicdoodleCore-1.6.2-a0.1.38.487.jar

    and here
    2013-08-25 19:07:39 [INFO] [ForgeModLoader] Searching C:\Documents and Settings\Parent\Desktop\modded server\mods for mods
    2013-08-25 19:07:39 [FINE] [ForgeModLoader] Found a candidate mod directory 1.6.2
    2013-08-25 19:07:39 [FINE] [ForgeModLoader] Found a candidate zip or jar file CodeChickenCore 0.9.0.3.jar
    2013-08-25 19:07:39 [FINE] [ForgeModLoader] Found a candidate zip or jar file Galacticraft-1.6.2-a0.1.39.566.jar
    2013-08-25 19:07:39 [FINE] [ForgeModLoader] Found a candidate zip or jar file MicdoodleCore-1.6.2-a0.1.38.487.jar
    2013-08-25 19:07:39 [FINE] [ForgeModLoader] Found a candidate zip or jar file NotEnoughItems 1.6.1.2.jar
     
  17. wolfbane3333

    wolfbane3333 Member

    Joined:
    Aug 22, 2013
    Messages:
    13
    Likes Received:
    0
    Weird cuz i double checked the file
     
  18. wolfbane3333

    wolfbane3333 Member

    Joined:
    Aug 22, 2013
    Messages:
    13
    Likes Received:
    0
    And even redownloaded it
     
  19. MasterOanarchY

    MasterOanarchY Moderator
    Staff Member

    Joined:
    Jul 3, 2013
    Messages:
    1,016
    Likes Received:
    38
    Maybe an old log. Clear out your logs and make a new one.
     
  20. wolfbane3333

    wolfbane3333 Member

    Joined:
    Aug 22, 2013
    Messages:
    13
    Likes Received:
    0

Share This Page