Invalid Oxygen Setup

Mart

Member
May 18, 2018
8
2
3
Hello,

I realise this is somewhat a wall of text, but I hope my issue will be clear-cut this way.

I made a small moon base which consists of two rooms seperated by a single air lock seal. Whenever I move through the air lock seal quickly, I get the invalid oxygen setup warning (and sometimes the accompanying damage) lasting for about the duration of a blink.

My base: both rooms are sealed; no holes, only used blocks are laboratory blocks from Chisel, air lock blocks and sealable Galacticraft blocks. Also, my oxygen and energy storage is abundant and the sealers always tell me the rooms are sealed (if I stay in one room or I remove the air lock altogether and make the base one big room, setup is fine).

I cannot: regularly walk or run across the air lock when it opens at either 1, 2 or 5 blocks distance, nor can I run through the air lock when it opens at 10 blocks distance, without getting the warning/damage. The only way to avoid the message/damage is by walking through the air lock when it opens at 10 blocks distance or up close when I wait walking across the air lock for 3 seconds when the air lock seal has opened (even though the other room has it's own sealer(s)).

What I tried: restarting the game several times, adding extra blocks at the edges of the base, using both versions of the air lock frame: without corners and with filled-in corners, placing a chunk loader (chunk loading ward from Extra Utilities 2), because the border of the two rooms is exactly at the border of two chunks. In some old post on the forum I read the sealing was done one chunk at a time or something along those lines, so I figured I should add a chunk loader, but it didn't work. I also added extra sealers, but alas.

I added two images: room A with machines and room B in which oxygen is being collected (double sealers because I was trying to find a fix).

Thank you for reading and getting to the end of the post!

MC 1.12.2
Forge 14.23.3.2655
GC 1.12.2-4.0.1.176
*custom modpack

edit: made a new room connected via air lock and sadly it happens here as well. Infinite battery/infinite oxygen tank do not solve the issue.
 

Attachments

  • 2018-05-22_01.28.54.png
    2018-05-22_01.28.54.png
    801.1 KB · Views: 6
  • 2018-05-22_01.29.11.png
    2018-05-22_01.29.11.png
    346.6 KB · Views: 7
Last edited:

radfast

Administrator
Staff member
Apr 27, 2014
1,142
353
83
My guess as to what's happening here:

  • In a space dimension, standard (vanilla) air blocks are not breathable - they count as "vacuum"
  • The Oxygen Sealer works by changing all air blocks in the sealed room to "Breathable Air" blocks
  • When the Air Lock opens, the blocks which make up the air lock door are deleted - when Minecraft deletes a block, it replaces it with a standard air block
  • It takes a small amount of time, maybe 1 second, for the Oxygen Sealer to notice those air blocks and convert them to Breathable Air
You'd probably see the same problem - momentarily invalid oxygen - if you break blocks at head height and walk immediately into the space where the broken block was - especially if your head is already inside the block you are breaking (like breaking a ladder or a sign or a torch).

For the Air Lock we can maybe fix this, make it place Breathable Air when it deletes the door blocks. That will maybe give a performance improvement too, could solve another problem I noticed...

----

There's nothing special about chunk borders for Oxygen Sealers, they work just as well at chunk borders. What you read is maybe years out of date? Please see the wiki updated today with some more info to cover this.
 
Last edited:

Mart

Member
May 18, 2018
8
2
3
This is probably what's happening; I got the invalid oxygen warning already by just standing in the frame and not walking any further. I checked and indeed, breaking ladders at head height gave me the same kind of warning.

At least I know why it is happening, thank you for that radfast! If you would decide on fixing it, that would be amazing too! (Just out of curiousity: what other problem did you notice?)

I bet it was pretty old, I was just trying whatever I could. I never moved more than one chunk away while trying to come up with a solution so it basically couldn't even have been the issue.

Thank you!
 
  • Like
Reactions: Ezer'Arch