Lag after 5 minutes of playing.

Does this happen to you too?


  • Total voters
    6

BlueRider

Member
Feb 23, 2013
25
5
3
23
Your game type (Server or Client): Client
Your Galacticraft Version: 0.08
Minecraft Version: 1.4.7
Minecraft Forge Version: 6.6.0.497
Any other installed mods: CustomMobSpawner, TF2_TeleporterMod, Optifine, Mocreatures
Error Report (if applicable): None
The game mode the bug occured in: Survival/Creative Multiplayer (Lan world with my brother, we've got the exact same plugins)

My brother doesnt have the same problem, i've looked at memory use, my minecraft keeps using more and more memory, until its unplayable because of lag.
 

micdoodle8

Administrator
Staff member
Nov 12, 2012
456
216
43
That would be a major memory leak. Try removing your other mods temporarily (including optifine), on a fresh world and tell me if that changes anything.
 

Dunewolfz

He-who-has-no-morals-or-sense-of-logic.
Staff member
Feb 23, 2013
794
155
43
Kalos Region
www.itanimulli.com
Your game type: Client
Your Galacticraft Version: 0.08
Minecraft Version: 1.4.7
Minecraft Forge Version: 6.6.0.497
Any other installed mods: (though I tested without and this still occurred); OptiFine, Pet Bat, Twilight Forest, More Bows, Rei's Minimap, and last but not least, Too Many Items. (I'm a mod freak :) )
Error Report: None (as of yet)
Occurred in: Survival (with cheats)

I too have this memory leak problem, and I have your average gaming PC. I play with numerous mods, but test them all out separately to make sure they're in working order. Galacticraft is bug free except for what the OP said, this massive memory leak. I've played it on a new world with all other mods disabled (note that I use Magic Launcher since I'm scared to actually change .minecraft itself). This memory only seems to happen while on the moon and returning from, not before launching to the moon. This memory leak didn't happen the first time on the moon though, but it did every time afterwards. I've also tried doing all the standard game-boosting things, such as fast everything with OptiFine, running MC with 64bit Java on High Priority, etc, and it still occurs with the same ill-fated effects.
If you'd like to know: Allocated memory is set at 494MB (ML refuses to let me have it higher), without the leak it averages about 30-40% usage, with the leak it goes all the way to 99% with no going down. Java version: 1.7.0, Version 7 Update 10.

EDIT:
I believe I've found the problem, it's likely OptiFine, as I played with each of the mods and GC. When I played with GC and OptiFine enabled, GC and OptiFine just didn't quite get along. I'm guessing I missed OptiFine when I was disabling the other mods. I, naturally, could be wrong but I'm pretty sure OptiFine is the problem when it comes to the leakage problem. Not a major blow to me personally, but I'm sure there are plenty of people out there who have this mod and need OptiFine.
 

micdoodle8

Administrator
Staff member
Nov 12, 2012
456
216
43
Okay, thanks for narrowing that down..

Are you using Optifine D5?

Did you install Optifine after forge?

Try updating forge, see if that helps at all. I'm using the latest Forge with Optifine D5 and Galacticraft 0.0.9... no memory leak.
 

flashman111

Moderator
Staff member
Feb 12, 2013
1,068
149
63
I suggest always installing things like this:
1. Forge
2. Optifine
3. RenderPlayer Pack
 

BlueRider

Member
Feb 23, 2013
25
5
3
23
It should be noted that my brother doesnt have this problem, and we are playing together with the same mods except optifine which only i use. I am using magiclauncher and fml to load mods. It should also br noted that i am with an alienware m17x r4 with 8gb ram, 2gb gtx 680m and 3500mb allocated to minecraft
 

Dunewolfz

He-who-has-no-morals-or-sense-of-logic.
Staff member
Feb 23, 2013
794
155
43
Kalos Region
www.itanimulli.com
Your game type (Server or Client): Client
Your Galacticraft Version: 0.08
Minecraft Version: 1.4.7
Minecraft Forge Version: 6.6.0.497
Any other installed mods: CustomMobSpawner, TF2_TeleporterMod, Optifine, Mocreatures
Error Report (if applicable): None
The game mode the bug occured in: Survival/Creative Multiplayer (Lan world with my brother, we've got the exact same plugins)

My brother doesnt have the same problem, i've looked at memory use, my minecraft keeps using more and more memory, until its unplayable because of lag.

Try this:
Update from GC 0.0.8 to 0.0.9, I did that and just about all of the leakage cleared up. Naturally the last thing I try was the one that fixed it all...
 

Blakemc

Member
Feb 23, 2013
22
1
3
31
i still get a short lag spike that drops my frames horribly about every minute even after the new version, also air lock doors wont work correctly, then i have to reset the map to make them work, anyone else?
 

Dunewolfz

He-who-has-no-morals-or-sense-of-logic.
Staff member
Feb 23, 2013
794
155
43
Kalos Region
www.itanimulli.com
i still get a short lag spike that drops my frames horribly about every minute even after the new version, also air lock doors wont work correctly, then i have to reset the map to make them work, anyone else?
How much memory do you have allocated towards minecraft and what are your OptiFine settings?
The biggest thing I'd suggest doing is setting OptiFine to have smooth world generation if you haven't already. If you have the default autosave on (2s) it can also cause this because the saves begin to build up and cause a massive lag spike which repeats every few minutes. Try putting autosave to 2 or 3 minutes.
 

flashman111

Moderator
Staff member
Feb 12, 2013
1,068
149
63
I suggest turning on Advanced OpenGL if your Graphics Card supports it and setting chunk loading to multicore. Then go under "Performance" and enable everything except for lazy chunk loading
 

Blakemc

Member
Feb 23, 2013
22
1
3
31
How much memory do you have allocated towards minecraft and what are your OptiFine settings?
The biggest thing I'd suggest doing is setting OptiFine to have smooth world generation if you haven't already. If you have the default autosave on (2s) it can also cause this because the saves begin to build up and cause a massive lag spike which repeats every few minutes. Try putting autosave to 2 or 3 minutes.
96%-100% allocated, my setting are the fasest mostly. and i do have smooth world gen on, and my autosave is 30.
 

Blakemc

Member
Feb 23, 2013
22
1
3
31
I suggest turning on Advanced OpenGL if your Graphics Card supports it and setting chunk loading to multicore. Then go under "Performance" and enable everything except for lazy chunk loading
i have advanced opengl to fast and i dont have the chunk loading option for some reason? in performance i have everything selected except, load far, lazy chunk loading, and preloaded chunks. im on the shittiest settings still lag spike. :/ also im using john smith legacy texture pack "HD".
 

Blakemc

Member
Feb 23, 2013
22
1
3
31
So i turned off smart moving 1.4.7 mod and now im loading fine without a lag spike. also my allocated memory is 50% im thinkin smart moving is just not working well with this mod. idk maybe the spike will come back.
 

Dunewolfz

He-who-has-no-morals-or-sense-of-logic.
Staff member
Feb 23, 2013
794
155
43
Kalos Region
www.itanimulli.com
Do you have the latest OptiFine? Chunk loading on smooth/multicore is extremely important for smooth gameplay. Also, you have an HD texture pack, which is, naturally, more demanding than the default. Try using the default for a little bit and see if you find any massive difference. Do you know what your graphics card is? I know all small amount of computers actually work slower when OpenGL is on. Oh yeah, and make sure you have 0.0.9 GC version, the 0.0.8 version had a memory leak problem with OptiFine.

EDIT: I can't edit in a reply, odd. Anyways, yeah, smart moving does not get along well with this mod, it has been reported before I believe, but Micdoodle is working on it.
 
  • Like
Reactions: Blakemc

Blakemc

Member
Feb 23, 2013
22
1
3
31
Do you have the latest OptiFine? Chunk loading on smooth/multicore is extremely important for smooth gameplay. Also, you have an HD texture pack, which is, naturally, more demanding than the default. Try using the default for a little bit and see if you find any massive difference. Do you know what your graphics card is? I know all small amount of computers actually work slower when OpenGL is on. Oh yeah, and make sure you have 0.0.9 GC version, the 0.0.8 version had a memory leak problem with OptiFine.

EDIT: I can't edit in a reply, odd. Anyways, yeah, smart moving does not get along well with this mod, it has been reported before I believe, but Micdoodle is working on it.
Yes, im using Optifine 1.4.6 HD D5, and my graphics card is ATI Radeon HD 3200 Graphics, and yes i just updated GC today.