More Planets Not Working

Discussion in 'Support' started by Without, Mar 4, 2019.

  1. Without

    Without Member

    Joined:
    Mar 4, 2019
    Messages:
    1
    Likes Received:
    0
    Hi, I have not been able to find a solution anywhere else, so I made an account here. I am playing on 1.7.10 , when I download Galacticraft More Planets, It just doesn't work. None of the new planets or moons appear on the galaxy map, I can't find any of the new blocks and items in the creative inventory, etc. the game basically acts like the mod isn't in my folder, even though Forge mod loader says it is. I have tried about 5 versions of the 1.7.10 mods, and all I have installed is forge, micdoodle8, galacticraft core, and galacticraft planets. I even tried reinstalling Forge, and even non-galacticraft related mods work. Even Galaxy Space works! What do I do?!
     
  2. Rory_merchury

    Rory_merchury Member

    Joined:
    Apr 13, 2017
    Messages:
    6
    Likes Received:
    2
    Make sure you install the mod correctly apart from that make sure you download from official site. it may be that you downloaded the version for the wrong mc version.
     

Share This Page