News: Galacticraft 3 beta works for both 1.7.2 and 1.7.10

radfast

Administrator
Staff member
Apr 27, 2014
1,142
353
83
In case people didn't spot micdoodle8's tweet today. https://twitter.com/micdoodle8

Thanks to some awesome coding overnight by micdoodle8, the same download (which is now called Galacticraft-beta-1.7-3.0.0.136 - notice how that's 1.7 not 1.7.2) will now work for either version 1.7.2 or 1.7.10 of Minecraft.

For Minecraft 1.7.2 you will need Forge10.12.2.1147, that's the latest 1.7.2 version.of Forge.
For Minecraft 1.7.10 you will need Forge10.13.0.1180, that's the recommended 1.7.10 version of Forge.

Make sure the other mods you use - from NEI + CodechickenCore, IC2 or whatever else you play with - are built for the correct Minecraft version. You get the exact same Galacticraft features in either version. So just play whichever version of Minecraft best suits the other mods you want to use.
 
  • Like
Reactions: MoltonMontro

radfast

Administrator
Staff member
Apr 27, 2014
1,142
353
83
There are issues with compatibility with IC2-experimental 1.7.10 version. We hope to resolve these in the next 2 days.
 
  • Like
Reactions: MoltonMontro

Ezer'Arch

Administrator
Staff member
May 18, 2013
1,611
449
83
ezerarch.com
@radfast , I tried to install GC3 1.7.10-136, but I'm getting a weird error. Every time I try to launch MC.I keep getting this pop-up:
MicdoodleCore Update Required!
Galacticraft and MicdoodleCore should always be at the same version
Severe issues can be caused from not updating

I have installed all 3 jars of the version 136. I figured out Galacticraft is trying to load other GC jars saved in any subfolder I might have in mods folder (e.g. minecraft/mods/backup_164).
 

radfast

Administrator
Staff member
Apr 27, 2014
1,142
353
83
This subfolders things should be fixed in forthcoming build 144.