⚠ Important Status of the Mod: When will a new feature or the next update be released?

Nilander

Member
Dec 31, 2016
2
1
1
22
Hey, I would, and I think a lot of people would too, love to see Galacticraft on 1.8 - 1.10.2 - 1.11.2

It would be awesome if someone could update it, or at least, tell me when is it gonna be updated, specially because I wanna add this mod to my moded server so me and my friends could play it.

Thanks a lot!
 

pra

Member
Mar 7, 2015
331
120
43
32
Overworld
Will the new things (like Venus) be backported to 1.7.10? Or the API changes at least, if there are any? I'm wondering at which point I should start porting my addon to 1.8.9 as well, and whenever it is realistic to keep adding features to both versions.
 
Aug 26, 2013
84
8
8
21
I know that you don't want to give a relase date, and that I've been warned enough times not to ask for it, yet I want to know if it would be possible to give a simple feedback about the state of the next update, by simply telling the scale of the remaining time until relase. Years, or a few months, or it could be out just in a couple of weeks?
 

SnailsAttack

Member
Jan 8, 2017
18
3
3
24
Well, if we give any idea of remaining time, it would be an ETA anyway. But we are near the end of the Yellow Brick Road.


o shit an actual update on stuf

I would guess thats venus. xD
Now that I pay closer attention to it, that worldgen is amazing! Reminds me of how venus might actually look.
 
  • Like
Reactions: Ezer'Arch

Vigilantecow

Member
Oct 5, 2013
443
118
43
Some Place Cold
moonquest.com
  • Like
Reactions: Ezer'Arch

C.L.

Member
Jul 4, 2016
54
13
8
Why not just go with 4space if you want to go to Venus? (I know they don't have faithful 32x32 support but people could work on it.)
 
Aug 26, 2013
84
8
8
21
Am I wrong, or are you talking about addons? Not Venus is what I really want... I didn't even go to the asteroid belt while the mod had it. I would only like to play it with my friend for a little. But that isn't possible. The most up to date version of this mod requies an old version of Java, that is no longer available for anyone. (they just won'T let anyone have it, for some reason)
 

Ezer'Arch

Administrator
Staff member
May 18, 2013
1,603
446
83
ezerarch.com
Am I wrong, or are you talking about addons?
There's a "GC4: Venus release" in the making. It was C.L. who came up with the idea of installing addons meanwhile.

As to Java version, what version are you running on? I have MC 1.7.10 through 1.10.2 installed, and GC and other mods too, they all use Java 8 JRE 1.8.0_121 (January 17, 2017).

Well I just use faithful, not other texture packs.
You can also unzip the resource pack zip, delete all folders except {resource_name}\assets\ambiotic. You still get the sound effects; no texture changed.
 
Last edited:

C.L.

Member
Jul 4, 2016
54
13
8
You can also unzip the resource pack zip, delete all folders except {resource_name}\assets\ambiotic. You still get the sound effects; no texture changed.
By that I mean I only use faithful and addons and modded editions. But carry on!