⚠ Important Status of the Mod: When will a new feature or the next update be released?

Aug 26, 2013
84
8
8
21
As to Java version, what version are you running on? I have MC 1.7.10 through 1.10.2 installed, and GC and other mods too, they all use Java 8 JRE 1.8.0_121 (January 17, 2017).
Took me at least 3 hours to find a way to make it work, and now it's fine. I've encountered countless problems, having to solve each in unique ways. I had a great time fixing everything, I may do a post on how to fix all those problems. I'm totally happy for now. Glad I found that Forge patch that makes things work with Java8. Also, btw: the simple way is to use 1.7.10 just as you do, should have no problems. I wanted 1.7.2, where, well... sh|t happens.
 
  • Like
Reactions: Ezer'Arch

samandsalmon

Member
Feb 21, 2017
2
1
3
57
Hey there man Ezer ,idk if I am doing this forum thing wrong, I just wanted to know will there be an armour (Space suit) coming to galacti craft. It's just galacti craft is perfect as far as a man like me can tell expect for the fact that there are no space suits it's a mod all about space. But that's just me. Like I said I am new to this forum thing well in fact mods in general; and as far as I can tell you are or know a/the galacti craft dev(s) and you could tell me this if you are a dev I want to say Thanks and if you know a/the dev(s) plz say Thanks for me for such a great mod.

FYI if you do respond to me and I forget say thanks then I'll say it now Thanks~. ;):D

P.S. will there be any weapons added to galacti craft energy sword energy guns to help defend against the mutant mobs
 
Last edited:

Ezer'Arch

Administrator
Staff member
May 18, 2013
1,603
446
83
ezerarch.com
Thanks Thanks Thanks~.
Your post is such a small army of thanks. :D

As to a proper space suit: there's nothing for it, at least not as what people often come up with. Instead, we'll get a Tier 2 Thermal Padding for Venus. We had a long discussion about space suit here. You can also retexture one of Vanilla/Galacticraft armors and pretend it's a space suit (like I did).

As to new weapons or mutant mobs: nope.

A new energy tier? Yes, for vapor.
And a big nope too.
 

samandsalmon

Member
Feb 21, 2017
2
1
3
57
This may seem less valuable now that I have already said thanks and so many others "
Your post is such a small army of thanks." but thank you for letting me know, and sorry my thanks was delayed I just had not checked in a while.


Also I subbed to your YouTube
 
  • Like
Reactions: Ezer'Arch

TheRedstoneT

Member
Mar 27, 2017
2
0
1
19
Can you please add support for 1.11.2 as i would LOVE to use this mod? u dont have to add like any mobs or anything, pls just 1.11.2 support :(
 

Lykaios

Member
Mar 30, 2017
1
0
1
23
I love this mod, but minecraft 1.7.10 is so old i think. In my opinion play Galacticraft in minecraft 1.10.2 will be wonderfull with the new mechanics like cooldown.

I'm waiting this update a lot of time, please make this possible :D

Thanks for read, and sorry for my english.
 

MJRLegends

Member
Mar 13, 2015
527
63
28
I love this mod, but minecraft 1.7.10 is so old i think. In my opinion play Galacticraft in minecraft 1.10.2 will be wonderfull with the new mechanics like cooldown.

I'm waiting this update a lot of time, please make this possible :D

Thanks for read, and sorry for my english.
The developers are working very hard on 1.8.9 & 1.10.2 ports and they are starting on 1.11.2 port. They will be out when they are ready :D
 
  • Like
Reactions: Ezer'Arch

radfast

Administrator
Staff member
Apr 27, 2014
1,142
353
83
> I'm waiting this update a lot of time, please make this possible

@Lykaios You can help in three ways.

1) You can beta test the 1.8.9 version, see the thread in the General forum area about this. Note that you are advised not to make detailed builds in the beta version: you could lose blocks or items if we change something before final release.

2) You can translate Galacticraft into your language (Greek?) This will be greatly appreciated, it will help other players in your country. There is a sticky thread here about how to do it. It's simpler in 1.8.9 and later Galacticraft versions, there are only 2 files to translate.

3) We can always use help with models and texturing. Have a look at existing models, block textures and item textures in the mod, and see if there's anything you feel like improving.
 

C.L.

Member
Jul 4, 2016
54
13
8
@Ezer'Arch Since the 4space on the official site is so outdated and that there's no valid thermal protection for it on pluto(not even the thermal padding works :mad:), will you add all the moons and stuff that the old 4space mod has?

BTW, I still use the 1.7.10 version, so keep up the good work on it.
 
Last edited:

John Taylor

Member
Feb 12, 2020
1
0
1
50
Just wondering, which version is being worked on next? (I'm hoping 1.14 but 15 would be great to). Thanks
 

HyXeRion

Member
Nov 27, 2015
18
1
3
18
Hey everyone !
I wanted to ask you, if in the future you decide to update the mod to an newer version of minecraft, will the mod being updated for the previous versions of minecraft ?
English is not my native langage so i'm sorry if it's not easily understable.
I explain my mind if it's not, If the mod is update to 1.15 with new features etc,will the features be added for 1.12.2 version too ?
I know how time-eater the programmation is, I don't ask any additionnal work from you, your mod is wonderful ^^ i'm just wondering if you want to evolve with the game or in a precise version.
Good day !