White Sky

GeneralPho

Member
Jun 4, 2017
11
3
3
28
Hi,

So recently while playing, I notice that sometimes when I am on the moon, the lower half of the sky is completely white. In addition, while in the asteroids dimension the same problem occurs as well.

Playing on build 116.
 

Attachments

  • white.png
    white.png
    54.8 KB · Views: 14

Ezer'Arch

Administrator
Staff member
May 18, 2013
1,611
449
83
ezerarch.com
Since you have other mods installed, we need to know if it's Galacticraft fault or it is another mod affecting Galacticraft.

Please back up your world and:
1. Reproduce the bug, in the same place, with GC only. If the bug goes away:
2. Add back the mods, one by one (starting with Optifine), until the bug happens.
 

MadMikael

Member
May 6, 2018
3
1
1
42
I had this same issue... so comparing mod lists, the only two we had in common were optifine and jei
The culprit was indeed optifine - once I removed that, the sky went back to normal again.
It's a shame - I rather like some of the advanced options optifine offers
the version I had was 1.12.2_HD_U_D1

Basically, the lower part of the sky was bright white - and annoying in contrast to the moon colours
The moon was fine when I first landed; but after loading up a save it was like that :(
maybe I could tweak some options and figure out what's causing it - but I'm just glad to have Galacticraft up and running again (I've been looking forward to it for a long time....)

So if anyone else has this issue, it's definitely something done by optifine
 

radfast

Administrator
Staff member
Apr 27, 2014
1,142
353
83
If you have any SHADERS running, you will - of course - need to disable them in Optifine when you are not on the Overworld. Shaders are for the Overworld only.
 

MadMikael

Member
May 6, 2018
3
1
1
42
Alright, I tried to reproduce as best I could.
Using just Galacticraft 176 and Optifine, on creative, I could not do it.
Using 175 and Optifine I could not do it.
Tried with and without my resource pack.
So, I decided to add Optifine back into the mix on my current game, and return to the moon - sure enough, it happened again (after a quit and restart on the moon).
Tried some crazy things (after a backup) - removed all mods besides those - no luck. Tried replacing the Galacticraft mods with the updated ones too.
I don't know, maybe it's save specific, or it's another mod that's creating a combination effect - I've noticed a few weird happenings on Mars that should not be.
For example - using the cryo chamber, does change night into day, but the day/night cycle is somehow not affected - what I mean is, even though graphically I see day time, mobs and solar panels are unchanged - I'll see zombies etc. walking around at day, and dying at night lol. Also, solar panels will not see the sun above them, but will be pointed at the ground at night and generating energy... I've found that quitting to main menu and resuming fixes this. Also sometimes turning the panels around 360 degrees with a wrench works too (usually).
And I get another bug that should already be fixed as well - using launch controllers between planets, the sound of the rocket continues well after landing. I'm betting it's likely another mod I've used that's messing with this. Also, unsure if it's supposed to happen or not, but when getting out of a tier 2 rocket on the overworld, I get fall damage :(

I am using DrZhark's Mo' Creatures mod - but when I first arrived at the moon, I found no mobs... turns out it was the Custom Spawner - which I uninstalled (with adjusting the flag/restarting a couple times as instructed), but I continued the same game - maybe that messed something up.
Also, this game was played LAN for a bit, and while I uninstalled it, my gf did not right away... so yeah, the save file is probably messed. I was thinking of starting over anyway.

All the other mods I have I could live without as well.... DaVinci's Vessels (and moving world) is useful for gathering livestock, but other than that I don't use it.
Just Enough Items and JourneyMap I could live without easily, but they're just convenient.
I do use Xray (I think it's advanced xray), but that's just for finding ores really so I don't spend more time mining than I have to lol. It was a little buggy though - it did not like the different tin ores on the overworld, moon, and mars - and I had to re-add them each time (although the color I picked was saved); and I had to restart minecraft totally to get the new ore to show.

Sorry for the long answer, but since you gave such a quick reply, I figured that meant you were interested.
I figure the more details I give, the more you may have an idea on what the issue is - and maybe you have an idea of what other mod I used that might have caused this (or even if it was LAN related, idk). If you have any ideas, questions, etc. please let me know - I'll see if I can try again perhaps. Maybe I'll just do an actual game with Galacticraft 176 and Optifine (not creative), and see if it happens. I didn't actually build anything on my quick tests today (just enough to get me to the moon) - so I could give that a go too.
 

MadMikael

Member
May 6, 2018
3
1
1
42
It would also be good if you can test for us - on your PC - with only Galacticraft + Optifine installed.

Hey, I got it - I can reproduce it, and I can do a workaround too ;)

Galacticraft Core/Planets, and MicdoodleCore versions 1.12.2 4.0.1.176
OptiFine_1.12.2_HD_U_D1

Thought about what options I had different in my main game than in my test versions.
Note that I turn mipmaps off as they drag my fps down ridiculously when I use a resource pack.
It's directly tied to the "fast render" option under performance.
I loaded up my test game in creative again, turned on fast render, no issue; restarted minecraft (with the save file having it on), and got the white sky.
Turning it off in game gives me a white screen.... turn it back on, and game comes back with sky issue.
However, if you save and quit to title, (not restart minecraft), turn the fast render off, then load your game... well, you get white screen on load up, but then you can turn it back on again and voila! Sky problem solved, and game loads really quick. These issues happen both with default and my chosen resource pack.
The problem seems to be gone until minecraft is restarted; i.e. I can save and quit to title, reload multiple times and I don't get the white sky issue again after doing my above workaround.
Maybe this tells you why this happens? Hope so. And in the meantime, I can still play ;)
 
  • Like
Reactions: RarePlutonian

radfast

Administrator
Staff member
Apr 27, 2014
1,142
353
83
Good job, really nice work figuring it out with the steps to reproduce.
I'll try and see if I can get the same to happen, next time I'm at my gaming PC.
This could be a bug in Optifine - especially with it happening differently if Minecraft is restarted, we are not doing that. We will look to see if we have a way to "switch off" or bypass this problem in Optifine. Your info will be very helpful with that.
 
  • Like
Reactions: RarePlutonian