Basic components is gone?

PureTryOut

Member
Mar 5, 2013
213
19
18
27
Haven't played this mod for a while, but I noticed basic components seems to be gone from Galacticraft?
Before trying the 1.6.4 version of Galacticraft I tried Voltz, in which I used the battery box and copper wire from Basic Components to store and transfer energy.
But because it seems to be missing in 1.6.4, I have no good way to use energy.

I found Galacticraft now has a energy storage module - which seems to be the replacement of the battery box - and aluminium wire. But when using energy made by for example a wind mill (which I think is part of Mekanism?), it won't go in the energy storage module, although all wires seem to connect.
Only power made from solar panels (from Galacticraft, not the Mekanism ones) seem to work with the energy storage box.

I know Basic Components was removed from UE from 1.5.2 and onwards, but is there a way to re-enable them in 1.6.4 with Galacticraft? I can't seem to find a config option for it.

EDIT: Also, when following the video Micdoodle linked, he was given a popup in which to enable Basic Components. I do not have that option.
The only thing I have installed at the moment is Forge 9.11.1.965, Galacticraft v2.0.8.908, MicdoodleCore v2.0.8.908, and Galacticraft Planets v2.0.8.908.
 
Last edited:

Jorjenator

Member
Feb 10, 2014
1
0
1
37
"EDIT: Also, when following the video Micdoodle linked, he was given a popup in which to enable Basic Components. I do not have that option.
The only thing I have installed at the moment is Forge 9.11.1.965, Galacticraft v2.0.8.908, MicdoodleCore v2.0.8.908, and Galacticraft Planets v2.0.8.908."

I am having the same issue when trying to play Galacticraft. My verson of minecraft is cracked so I am not sure if this is the problem. I am certain I followed the directions correctly, but the pop up for "load basic components" never came up.
 

PureTryOut

Member
Mar 5, 2013
213
19
18
27
My verson of minecraft is cracked so I am not sure if this is the problem.
First of all, that is not your problem. It still uses the same minecraft code, just the launcher is changed. I do advise you to buy the official version though.
Nobody will help you any further if you keep on playing with a cracked game. We don't like people who don't pay for Minecraft.
Please go play Minecraft classic on minecraft.net (if it's still there), that is a free version.

It has been removed AAGES ago.
Then please explain to me why it does appear on the 1.6.x version shown in this video.
 
Jan 8, 2014
1,049
129
14
43
Sweden not really swedish im dutch
First of all, that is not your problem. It still uses the same minecraft code, just the launcher is changed. I do advise you to buy the official version though.
Nobody will help you any further if you keep on playing with a cracked game. We don't like people who don't pay for Minecraft.
Please go play Minecraft classic on minecraft.net, that is a free version.


Then please explain to me why it does appear on the 1.6.x version shown in this video.
It has been removed because mitch has added his own stuff. so there is no basic componements galacticraft does not use it anymore!
 

PureTryOut

Member
Mar 5, 2013
213
19
18
27
Well that is not necessarily a bad thing...
Can somebody tell me then how to connect other power sources (like the windmill from Mekanism) to Galacticraft technology?
Or do I just have to wait till proper support is added? I believe Micdoodle was working on it right?
 

PureTryOut

Member
Mar 5, 2013
213
19
18
27
Uuugh i'm sorry, I forgot to mention in my first post so i'll add it in here (the bold text is added in):
I found Galacticraft now has a energy storage module - which seems to be the replacement of the battery box - and aluminium wire. But when using energy made by for example a wind mill (which I think is part of Mekanism?), it won't go in the energy storage module, although all wires seem to connect. The universal cables won't even connect to anything added by Galacticraft.
Only power made from solar panels (from Galacticraft, not the Mekanism ones) seem to work with the energy storage box.

So again, no proper way to use energy from other mods at this moment.
 

PureTryOut

Member
Mar 5, 2013
213
19
18
27
I'm using the recommended version atm, 2.0.8.908.
I tried the latest development version too, still doesn't work though.
 

PureTryOut

Member
Mar 5, 2013
213
19
18
27
What? Why do you think I don't want help? I made this thread because I want help!
And how am I deaf, you asked if I used an old version (at least I think you did), so I answered what version I use!
 

Douglas_Fresh

Member
Sep 17, 2013
797
241
63
36
Seattle, WA, USA
www.youtube.com
Are you def? im trying to help you but you dont want help sooo fuck off!

Yeah, where did that come from?! Seemed like a perfectly acceptable answer to me.

What? Why do you think I don't want help? I made this thread because I want help!
And how am I deaf, you asked if I used an old version (at least I think you did), so I answered what version I use!

Perhaps he meant an old version of Mekanism?
 

PureTryOut

Member
Mar 5, 2013
213
19
18
27
Well i'm using Mekanism version 5.7.0.11. But checking the Mekanism site again it seems version 6.x has been released just 3 hours ago so I will try that now.
 

PureTryOut

Member
Mar 5, 2013
213
19
18
27
Ooh well i'm sorry but I only quote when I think a certain sentence is really needed for the conversation to continue. Still, such a reaction was not necessary
Anyways tried using Mekanism 6.0.1.13, it still doesn't work. Galacticraft wires not connecting to Mekanism, same other way around.