A weard type of lag!

Bjornar97

Member
Sep 4, 2013
3
0
1
25
I was installing forge, MicdoodleCore-1.6.2-a0.1.39.626.jar and Galacticraft-1.6.2-a0.1.39.626.jar. I started a map and some times it lagged, but not that much, but it became worse and worse, today I installed the latest version of Galacticraft, Galacticraft planets and micdoodleCore, Version a0.1.39.653. I had like 70 fps in the start, and i went mining, but some time later I got Horrible lag, I had from 14-30 fps, but felt like 0-1 fps, and that was on far, but it was the same lag on tiny. I dont know why, but it is not RAM, because I tried with 3 GB, but the same lag.

It was not normal fps-drop, it was some lag I never have seen before.

Can you Please help me fix this!

BTW, sorry for my bad English
 

Attachments

  • Minecraft Log.txt
    24.4 KB · Views: 4
Last edited:

Ezer'Arch

Administrator
Staff member
May 18, 2013
1,611
449
83
ezerarch.com
I'd like to confirm this weird lag.

On my end, while playing #642 on Mars, the lag starts almost unnoticeable and increases progressively until the game shuts down. I had to update to #647, now the lag happens mostly on Overworld and almost nothing on Mars. The game keeps frame-skipping, every 60 Frames it skips 1. Player and camera movements aren't smooth because the game keeps ticking, itching, hiccuping every second and gets worse as I play.
 

Bjornar97

Member
Sep 4, 2013
3
0
1
25
I have Nvidia Geforce GT 650M graphics Card, and Intel Core i7 ivy bridge 2.6 Ghz processor. And I can run Tekkit, FTB and many other modpacks with 70-150 Fps. So I dont have a slow computer, and i have not AMD.

But I discovered that it is only lagging underground. On the surface, I have over 50 fps.
AMD Radeon HD 7970
I can safely say that it is a problem with GC.
AMD Radeon HD 7970
I can safely say that it is a problem with GC.
 

Dunewolfz

He-who-has-no-morals-or-sense-of-logic.
Feb 23, 2013
793
154
43
Kalos Region
www.itanimulli.com
I have Nvidia Geforce GT 650M graphics Card, and Intel Core i7 ivy bridge 2.6 Ghz processor. And I can run Tekkit, FTB and many other modpacks with 70-150 Fps. So I dont have a slow computer, and i have not AMD.

But I discovered that it is only lagging underground. On the surface, I have over 50 fps.
Okay, okay Mr. Technological powerhouse. It's a bug with the mod, probably a memory leak somewhere.
 
Sep 10, 2013
5
0
1
66
Yeah I have to say that its a memory leak as well. Everyone is getting this fps lag that is dropping off a lot. Was running regular minecraft last night started finally got the galaticraft working updated the memory and all that and now everyone is 100 fps less the standard minecraft from last night.
 
Sep 16, 2013
5
0
1
41
While not a resolution to the oil/water mixture. My friend and I were able to disable oil generation and that seems to have stopped all lag. The default value in core.cfg file is [1.8]

# Increasing this will increase amount of oil that will generate in each chunk.
D:"Oil Generation Factor"=0

1. Additionally, since the bug report seems to be locked, I did some more testing and a fresh forge with no mods no lag underground.
2. Then I added in Galacticraft only on the server, connected to my server via external IP address instead of my local computer name.
- (NOTE: this is only to make the lag more noticeable. Running single player on my main computer with a Solid State Hard drive doesn't seem to cause noticeable lag).
3. Went down underground and found some oil, forced confrontation/interaction with water and lava. After a bit the lag was noticeable moving around that area.
4. Blocked off all oil in the area and lag was reduced, however, it seemed to still be present.
5. Delete contents of world folder and recreate with setting on [0] for Oil Generation Factor.
6. NO lag is visible while in lower depths and while mining.

I think the only way to accurately validate would be to use a SEED to generate the same world with, and without oil.

There (may) be some interaction with build craft and its oil generation/mechanics as well (Assumption/guess). As it was more noticeable when I had it and the other mods I mentioned in that bug report installed.

This is just incase more information helps.
 
Sep 16, 2013
5
0
1
41
So I came home today and my server was unreachable. Tried remote desktop, no luck, tired UNC path, no luck. Turned on the servers monitor and it had this friendly message for me, "Invalid System Disk, please insert a new disk and press any key". So it appears my issues (MAY) have been a bad hard drive instead, once I get everything re-installed on a spare hard drive, i'll check again and reply.

Obviously this doesn't mean that the oil/water isn't hard drive/network/processor taxing situation, it may still be. But just wanted to give an update.

Also, to note, I am not this thread's original poster, and her/his issue may be different.
 
Sep 16, 2013
5
0
1
41
Ok, confirmed, it is the oil/water issue with lag. I have it disabled still on my server, yet leave the buildcarft oil enabled as it doesn't lag.
 

Dinammar

Member
Aug 31, 2013
657
151
43
27
London, United Kingdom
Intel i7-2600
CPU @ 3.40GHz
RAM 8.00 GB
Mine are:
LGA1366 Intel Core i7 965 Extreme edition
12GB RAM
MSI GTX285 HydroGen OC
O_O
Correct me if im wrong spelled something. It's on my pc spec paper thing that i had to write from


Those are good specs of yours. IDK why does it lag. I run it like 120fps on "fancy" graphics
 

Ezer'Arch

Administrator
Staff member
May 18, 2013
1,611
449
83
ezerarch.com
Try switching to "fast" graphics?
Fast graphics, Tiny View, Windowed mode: same thing, the game keeps hiccuping. When I rotate the head or walk I notice the game freezes for a few milliseconds every second. This is very tiring.

Then I created a new world. It fixed the lag for a bit. I went explore the caves, no lag until I found an oil spring fighting lava. Ticking-lag again. Now if I open the same world in a non-modded MC, the game runs smoothly and lag-less.
 

Kethrian

Member
Sep 30, 2013
24
20
3
45
Ive had similar symptoms but from a completely different source. This "hiccup" effect occurs when large number of O2 devices and pipes are linked up. Our large moon base became unplayable until we broke an oxygen line near the main o2 collector group (meteor strike amazingly). The hiccup stopped immediately and restarted as soon as the O2 network was reconnected.