1.12 Port?

Discussion in 'General' started by Booski62005, Sep 18, 2017.

Thread Status:
Not open for further replies.
  1. Booski62005

    Booski62005 Member

    Joined:
    Jan 16, 2016
    Messages:
    2
    Likes Received:
    0
    I'm not trying to bug Micdoodle8 by saying, "Make it 1.12 NOW!" but I'm just wondering if you've thought of it and how long it would take and what it would take.
     
  2. MJRLegends

    MJRLegends Member

    Joined:
    Mar 13, 2015
    Messages:
    351
    Likes Received:
    44
    Im sure it will be in the future but for right now there isn't any advancements towards 1.12+
     
  3. Ezer'Arch

    Ezer'Arch Administrator
    Staff Member

    Joined:
    May 18, 2013
    Messages:
    1,509
    Likes Received:
    416
    As usual (as well with 1.7.10, 1.8, 1.8.9, 1.10.2 and 1.11), there's no timeline or ETA for new releases. Micdoodle8 is busy with personal duties and Radfast is AFK (probably the same as mic).

    People are free to contribute with development and submit the code, I'll make sure to bug radfast or mic to review the code and merge it (if good). As always.
     
  4. SuperHammy3

    SuperHammy3 Member

    Joined:
    Mar 1, 2017
    Messages:
    37
    Likes Received:
    3
    If 1.12 were to come, it'd probably be a late version of GC4 or GC5.
     
  5. Dwight

    Dwight Member

    Joined:
    Sep 12, 2014
    Messages:
    68
    Likes Received:
    10
    Yeah, my playing group is just now starting up a server with mods for 1.12 Would LOVE to add Galacticraft

    But understand that things will come when they come
     
  6. radfast

    radfast Administrator
    Staff Member

    Joined:
    Apr 27, 2014
    Messages:
    1,086
    Likes Received:
    333
    I am not doing any work whatsoever on a 1.12 version, for now. I do not know if any other developer is working on this, but I doubt it, there is not even a branch for it.

    Currently I am looking at some of the issues in Galacticraft 4 including compatibility issues with other mods which are very time-consuming to solve, and also looking at completing some of the intended features for GC4 and a few things that micdoodle8 and I have planned in the pipeline.

    I never understand the eagerness of players to have a mod in the very latest Minecraft version (e.g. 1.12). What difference does it make to you, between 1.11.2 and 1.12? All the mods you want to play likely exist in 1.11.2 - indeed they're probably more stable for 1.11.2.
     
    Ezer'Arch likes this.
Thread Status:
Not open for further replies.

Share This Page