Addon [1.7.10 - 1.12.2] Extra Planets *Updated 14/08/2020*

7eggert

Member
Apr 20, 2018
17
0
1
43
When the levels on the bars become high you will be told with text matching the bar colour what that means

Got any ideas how to make this better let me know
Maybe you can write Radiation and Pressure onto the background of the bars.

All ExtraPlanets have names of the planet and moon in the names and JEI shows the recipes and process to create them/use them
E.g.: Where do I get Mercury?

As the tool tip on the space suit says the tier of space suit doesnt matter you can do the whole planet/moons to the end with the tier 1.
I assume to respawn instead, because higher tiers would protect me from radiation. I didn't have a chance to try it out, though, and Venus turned out to only mildly be too hot. OTOH I got a cyborg mod, and my implants are healing me, so I can't be sure.

oxygen compressors dont fill rockets??
Maybe they do fill classic oxygen tanks, maybe they don't. Maybe some advanced oxygen tanks can be filled, maybe not. Maybe it's only a question of speed …

Should be the same way you charge anything with power.
I have it in the inventory while near my wireless charger. Then I searched JEI for "charger" … one charger for cyber implants, one for robots, one for generic items, one for GC vehicles, one for railcraft rails …

Never having to use that, I didn't look for GC enery storage units, but now I automatically wrote "or I put it into a charging slot on my enderio capacitor which does not accept them". That might have been the clue, but with durability == 0 being my main concern, I tried that first. Then I disabled pressure damage and was protected by my regular armor.

Before going to Venus, I selected peaceful.

See GC wiki as its there system, you need to get a shield controller from Venus dungeons
… to conquer the moon dungeon to get the plans to build the rocket to go to Venus. But once you got the shield, you're good and I now have full durability, and it's easier if that bug on Venus gives infinite durability and energy to the space suit.

PS, the "h" key to add/remove modules from the space suit works while typing in JEI / the enderio inventory panel.
 

MJRLegends

Member
Mar 13, 2015
540
63
28
E.g.: Where do I get Mercury?
On Mercury haha

Maybe they do fill classic oxygen tanks, maybe they don't. Maybe some advanced oxygen tanks can be filled, maybe not. Maybe it's only a question of speed …
I'd recommenced just trying out the machines as you play. i will get some tool tips added though

PS, the "h" key to add/remove modules from the space suit works while typing in JEI / the enderio inventory panel.
Please report here https://github.com/MJRLegends/ExtraPlanets/issues
 

MJRLegends

Member
Mar 13, 2015
540
63
28
---------------------------------------------------------------------------------------------------------------------------------
1.12.2 Version:
Please report them here and use [1.12.2] in the title.
Requires Galacticraft 4 Builds, (174 Build and higher) and Forge 14.23.1.2555 or higher & Requires MJRLegendsLib as of ExtraPlanets!

v0.3.4 is available, check change log for details.
---------------------------------------------------------------------------------------------------------------------------------
1.11.2 Version
Please report them here and use [1.11.2] in the title.
Requires Galacticraft 4 Builds, (174 Build and higher) and Forge 13.20.1.2513 or higher & Requires MJRLegendsLib as of ExtraPlanets v0.5.0!

v0.7.1 is available, check change log for details
---------------------------------------------------------------------------------------------------------------------------------
1.10.2 Version
Please report them here and use [1.10.2] in the title.
Requires Galacticraft 4 Builds, (174 Build and higher) and Forge 12.18.3.2239 or higher & Requires MJRLegendsLib as of ExtraPlanets v0.8.6!

v1.0.6 is available, check change log for details
---------------------------------------------------------------------------------------------------------------------------------
1.8.9 Version:
Please report them here and use [1.8] in the title.
Requires Galacticraft 4 Builds, (174 Build and higher) and Forge 11.15.1.1764 or higher & Requires MJRLegendsLib as of ExtraPlanets v1.1.9!

v1.3.9 is available, check change log for details.
---------------------------------------------------------------------------------------------------------------------------------
 

MJRLegends

Member
Mar 13, 2015
540
63
28
---------------------------------------------------------------------------------------------------------------------------------
1.12.2 Version:
Please report them here and use [1.12.2] in the title.
Requires Galacticraft 4 Builds, (174 Build and higher) and Forge 14.23.1.2555 or higher & Requires MJRLegendsLib as of ExtraPlanets!

v0.3.5 is available, check change log for details.
---------------------------------------------------------------------------------------------------------------------------------
1.11.2 Version
Please report them here and use [1.11.2] in the title.
Requires Galacticraft 4 Builds, (174 Build and higher) and Forge 13.20.1.2513 or higher & Requires MJRLegendsLib as of ExtraPlanets v0.5.0!

v0.7.2 is available, check change log for details
---------------------------------------------------------------------------------------------------------------------------------
1.10.2 Version
Please report them here and use [1.10.2] in the title.
Requires Galacticraft 4 Builds, (174 Build and higher) and Forge 12.18.3.2239 or higher & Requires MJRLegendsLib as of ExtraPlanets v0.8.6!

v1.0.7 is available, check change log for details
---------------------------------------------------------------------------------------------------------------------------------
1.8.9 Version:
Please report them here and use [1.8] in the title.
Requires Galacticraft 4 Builds, (174 Build and higher) and Forge 11.15.1.1764 or higher & Requires MJRLegendsLib as of ExtraPlanets v1.1.9!

v1.4.0 is available, check change log for details.
---------------------------------------------------------------------------------------------------------------------------------
 

7eggert

Member
Apr 20, 2018
17
0
1
43
You do posts links to the requirements, but the links to the mod itself are missing. (Off cause there is the My Projects: HERE link).

Also: The signature is hidden when I'm not logged in.
 
Last edited:

MJRLegends

Member
Mar 13, 2015
540
63
28
---------------------------------------------------------------------------------------------------------------------------------
1.12.2 Version:
Please report them here and use [1.12.2] in the title.
Requires Galacticraft 4 Builds, (174 Build and higher) and Forge 14.23.1.2555 or higher & Requires MJRLegendsLib as of ExtraPlanets!

v0.3.6 is available, check change log for details.
---------------------------------------------------------------------------------------------------------------------------------
1.11.2 Version
Please report them here and use [1.11.2] in the title.
Requires Galacticraft 4 Builds, (174 Build and higher) and Forge 13.20.1.2513 or higher & Requires MJRLegendsLib as of ExtraPlanets v0.5.0!

v0.7.3 is available, check change log for details
---------------------------------------------------------------------------------------------------------------------------------
1.10.2 Version
Please report them here and use [1.10.2] in the title.
Requires Galacticraft 4 Builds, (174 Build and higher) and Forge 12.18.3.2239 or higher & Requires MJRLegendsLib as of ExtraPlanets v0.8.6!

v1.0.8 is available, check change log for details
---------------------------------------------------------------------------------------------------------------------------------
1.8.9 Version:
Please report them here and use [1.8] in the title.
Requires Galacticraft 4 Builds, (174 Build and higher) and Forge 11.15.1.1764 or higher & Requires MJRLegendsLib as of ExtraPlanets v1.1.9!

v1.4.1 is available, check change log for details.
---------------------------------------------------------------------------------------------------------------------------------
 

MJRLegends

Member
Mar 13, 2015
540
63
28
---------------------------------------------------------------------------------------------------------------------------------
1.12.2 Version:
Please report them here and use [1.12.2] in the title.
Requires Galacticraft 4 Builds, (177 Build and higher) and Forge 14.23.1.2555 or higher & Requires MJRLegendsLib as of ExtraPlanets!

v0.3.7 is available, check change log for details.
---------------------------------------------------------------------------------------------------------------------------------
1.11.2 Version
Please report them here and use [1.11.2] in the title.
Requires Galacticraft 4 Builds, (177 Build and higher) and Forge 13.20.1.2513 or higher & Requires MJRLegendsLib as of ExtraPlanets v0.5.0!

v0.7.4 is available, check change log for details
---------------------------------------------------------------------------------------------------------------------------------
1.10.2 Version
Please report them here and use [1.10.2] in the title.
Requires Galacticraft 4 Builds, (177 Build and higher) and Forge 12.18.3.2239 or higher & Requires MJRLegendsLib as of ExtraPlanets v0.8.6!

v1.0.9 is available, check change log for details
---------------------------------------------------------------------------------------------------------------------------------
1.8.9 Version:
Please report them here and use [1.8] in the title.
Requires Galacticraft 4 Builds, (177 Build and higher) and Forge 11.15.1.1764 or higher & Requires MJRLegendsLib as of ExtraPlanets v1.1.9!

v1.4.2 is available, check change log for details.
---------------------------------------------------------------------------------------------------------------------------------
1.7.10 Version:
Please report them here and use [1.7.10] in the title.
Requires Galacticraft 3 Builds, (502 Build and higher) and Forge 10.13.4.1614!

v2.0.2 is available, check change log for details.
---------------------------------------------------------------------------------------------------------------------------------
 
Last edited:

MJRLegends

Member
Mar 13, 2015
540
63
28
---------------------------------------------------------------------------------------------------------------------------------
1.12.2 Version:
Please report them here and use [1.12.2] in the title.
Requires Galacticraft 4 Builds, (177 Build and higher) and Forge 14.23.1.2555 or higher & Requires MJRLegendsLib as of ExtraPlanets!

v0.3.8 is available, check change log for details.
---------------------------------------------------------------------------------------------------------------------------------
1.11.2 Version
Please report them here and use [1.11.2] in the title.
Requires Galacticraft 4 Builds, (177 Build and higher) and Forge 13.20.1.2513 or higher & Requires MJRLegendsLib as of ExtraPlanets v0.5.0!

v0.7.5 is available, check change log for details
---------------------------------------------------------------------------------------------------------------------------------
1.10.2 Version
Please report them here and use [1.10.2] in the title.
Requires Galacticraft 4 Builds, (177 Build and higher) and Forge 12.18.3.2239 or higher & Requires MJRLegendsLib as of ExtraPlanets v0.8.6!

v1.1.0 is available, check change log for details
---------------------------------------------------------------------------------------------------------------------------------
1.8.9 Version:
Please report them here and use [1.8] in the title.
Requires Galacticraft 4 Builds, (177 Build and higher) and Forge 11.15.1.1764 or higher & Requires MJRLegendsLib as of ExtraPlanets v1.1.9!

v1.4.3 is available, check change log for details.
---------------------------------------------------------------------------------------------------------------------------------
 

MJRLegends

Member
Mar 13, 2015
540
63
28
---------------------------------------------------------------------------------------------------------------------------------
1.7.10 Version:
Please report them here and use [1.7.10] in the title.
Requires Galacticraft 3 Builds, (502 Build and higher) and Forge 10.13.4.1614!

v2.0.3 is available, check change log for details.
---------------------------------------------------------------------------------------------------------------------------------
 
Last edited:

MJRLegends

Member
Mar 13, 2015
540
63
28
---------------------------------------------------------------------------------------------------------------------------------
1.7.10 Version:
Please report them here and use [1.7.10] in the title.
Requires Galacticraft 4 Builds, (502 Build and higher) and Forge 10.13.4.1614!

v2.0.4 is available, check change log for details.
---------------------------------------------------------------------------------------------------------------------------------
 

MJRLegends

Member
Mar 13, 2015
540
63
28
---------------------------------------------------------------------------------------------------------------------------------
1.12.2 Version:
Please report them here and use [1.12.2] in the title.
Requires Galacticraft 4 Builds, (177 Build and higher) and Forge 14.23.1.2555 or higher & Requires MJRLegendsLib as of ExtraPlanets!

v0.3.9 is available, check change log for details.
---------------------------------------------------------------------------------------------------------------------------------
1.11.2 Version
Please report them here and use [1.11.2] in the title.
Requires Galacticraft 4 Builds, (177 Build and higher) and Forge 13.20.1.2513 or higher & Requires MJRLegendsLib as of ExtraPlanets v0.5.0!

v0.7.6 is available, check change log for details
---------------------------------------------------------------------------------------------------------------------------------
1.10.2 Version
Please report them here and use [1.10.2] in the title.
Requires Galacticraft 4 Builds, (177 Build and higher) and Forge 12.18.3.2239 or higher & Requires MJRLegendsLib as of ExtraPlanets v0.8.6!

v1.1.1 is available, check change log for details
---------------------------------------------------------------------------------------------------------------------------------
1.8.9 Version:
Please report them here and use [1.8] in the title.
Requires Galacticraft 4 Builds, (177 Build and higher) and Forge 11.15.1.1764 or higher & Requires MJRLegendsLib as of ExtraPlanets v1.1.9!

v1.4.4 is available, check change log for details.
---------------------------------------------------------------------------------------------------------------------------------
 

MJRLegends

Member
Mar 13, 2015
540
63
28
---------------------------------------------------------------------------------------------------------------------------------
1.12.2 Version:
Please report them here and use [1.12.2] in the title.
Requires Galacticraft 4 Builds, (178 Build and higher) and Forge 14.23.1.2555 or higher & Requires MJRLegendsLib as of ExtraPlanets!

v0.4.0 is available, check change log for details.
---------------------------------------------------------------------------------------------------------------------------------
1.11.2 Version
Please report them here and use [1.11.2] in the title.
Requires Galacticraft 4 Builds, (178 Build and higher) and Forge 13.20.1.2513 or higher & Requires MJRLegendsLib as of ExtraPlanets v0.5.0!

v0.7.7 is available, check change log for details
---------------------------------------------------------------------------------------------------------------------------------
1.10.2 Version
Please report them here and use [1.10.2] in the title.
Requires Galacticraft 4 Builds, (178 Build and higher) and Forge 12.18.3.2239 or higher & Requires MJRLegendsLib as of ExtraPlanets v0.8.6!

v1.1.2 is available, check change log for details
---------------------------------------------------------------------------------------------------------------------------------
1.8.9 Version:
Please report them here and use [1.8] in the title.
Requires Galacticraft 4 Builds, (178 Build and higher) and Forge 11.15.1.1764 or higher & Requires MJRLegendsLib as of ExtraPlanets v1.1.9!

v1.4.5 is available, check change log for details.
---------------------------------------------------------------------------------------------------------------------------------
 

PedroHSpavao

Member
Jun 30, 2016
4
0
1
20
complaint:

to craft a set of Tier 1 Space Suit you need 240 iron ingot this is too much for a simple armor and this value doubles when it is the Tier 2 (480 iron ingot), you literally wear tons of iron!

Change the craft's configuration of the anti-radiation armor. because it does not make sense.

The iron serves for various crafts spending so much on anti-radiation armor causes a lot of stress! and makes me want to stop playing.
 

Attachments

Last edited:

MJRLegends

Member
Mar 13, 2015
540
63
28
complaint:

to craft a set of Tier 1 Space Suit you need 240 iron ingot this is too much for a simple armor and this value doubles when it is the Tier 2 (480 iron ingot), you literally wear tons of iron!

Change the craft's configuration of the anti-radiation armor. because it does not make sense.

The iron serves for various crafts spending so much on anti-radiation armor causes a lot of stress! and makes me want to stop playing.
Im sure you have 240 iron its not that much when it comes to modded mc
 
  • Like
Reactions: PedroHSpavao

PedroHSpavao

Member
Jun 30, 2016
4
0
1
20
Im sure you have 240 iron its not that much when it comes to modded mc

I am sure that this is ideal since it is large quantities are offered for the player to have a very good start or a good exchange in the server markets

But in single player they do not have markets and the villagers do not make good exchanges, it gets very sparse the amount of iron in the single player.
but if your priority is the server I can not do anything

Addon is very interesting
 

MJRLegends

Member
Mar 13, 2015
540
63
28
---------------------------------------------------------------------------------------------------------------------------------
1.12.2 Version:
Please report them here and use [1.12.2] in the title.
Requires Galacticraft 4 Builds, (178 Build and higher) and Forge 14.23.1.2555 or higher & Requires MJRLegendsLib as of ExtraPlanets!

v0.4.1 is available, check change log for details.
---------------------------------------------------------------------------------------------------------------------------------
1.11.2 Version
Please report them here and use [1.11.2] in the title.
Requires Galacticraft 4 Builds, (178 Build and higher) and Forge 13.20.1.2513 or higher & Requires MJRLegendsLib as of ExtraPlanets v0.5.0!

v0.7.8 is available, check change log for details
---------------------------------------------------------------------------------------------------------------------------------
1.10.2 Version
Please report them here and use [1.10.2] in the title.
Requires Galacticraft 4 Builds, (178 Build and higher) and Forge 12.18.3.2239 or higher & Requires MJRLegendsLib as of ExtraPlanets v0.8.6!

v1.1.3 is available, check change log for details
---------------------------------------------------------------------------------------------------------------------------------
1.8.9 Version:
Please report them here and use [1.8] in the title.
Requires Galacticraft 4 Builds, (178 Build and higher) and Forge 11.15.1.1764 or higher & Requires MJRLegendsLib as of ExtraPlanets v1.1.9!

v1.4.6 is available, check change log for details.
---------------------------------------------------------------------------------------------------------------------------------
1.7.10 Version:
Please report them here and use [1.7.10] in the title.
Requires Galacticraft 3 Builds, (502 Build and higher) and Forge 10.13.4.1614!

v2.0.5 is available, check change log for details.
---------------------------------------------------------------------------------------------------------------------------------
 
Last edited:

MJRLegends

Member
Mar 13, 2015
540
63
28
---------------------------------------------------------------------------------------------------------------------------------
1.12.2 Version:
Please report them here and use [1.12.2] in the title.
Requires Galacticraft 4 Builds, (178 Build and higher) and Forge 14.23.1.2555 or higher & Requires MJRLegendsLib as of ExtraPlanets!

v0.4.2 is available, check change log for details.
---------------------------------------------------------------------------------------------------------------------------------
1.11.2 Version
Please report them here and use [1.11.2] in the title.
Requires Galacticraft 4 Builds, (178 Build and higher) and Forge 13.20.1.2513 or higher & Requires MJRLegendsLib as of ExtraPlanets v0.5.0!

v0.7.9 is available, check change log for details
---------------------------------------------------------------------------------------------------------------------------------
1.10.2 Version
Please report them here and use [1.10.2] in the title.
Requires Galacticraft 4 Builds, (178 Build and higher) and Forge 12.18.3.2239 or higher & Requires MJRLegendsLib as of ExtraPlanets v0.8.6!

v1.1.4 is available, check change log for details
---------------------------------------------------------------------------------------------------------------------------------
1.8.9 Version:
Please report them here and use [1.8] in the title.
Requires Galacticraft 4 Builds, (178 Build and higher) and Forge 11.15.1.1764 or higher & Requires MJRLegendsLib as of ExtraPlanets v1.1.9!

v1.4.7 is available, check change log for details.
---------------------------------------------------------------------------------------------------------------------------------
 

MJRLegends

Member
Mar 13, 2015
540
63
28
---------------------------------------------------------------------------------------------------------------------------------
1.12.2 Version:
Please report them here and use [1.12.2] in the title.
Requires Galacticraft 4 Builds, (178 Build and higher) and Forge 14.23.1.2555 or higher & Requires MJRLegendsLib as of ExtraPlanets!

v0.4.3 is available, check change log for details.
---------------------------------------------------------------------------------------------------------------------------------
1.11.2 Version
Please report them here and use [1.11.2] in the title.
Requires Galacticraft 4 Builds, (178 Build and higher) and Forge 13.20.1.2513 or higher & Requires MJRLegendsLib as of ExtraPlanets v0.5.0!

v0.8.0 is available, check change log for details
---------------------------------------------------------------------------------------------------------------------------------
1.10.2 Version
Please report them here and use [1.10.2] in the title.
Requires Galacticraft 4 Builds, (178 Build and higher) and Forge 12.18.3.2239 or higher & Requires MJRLegendsLib as of ExtraPlanets v0.8.6!

v1.1.5 is available, check change log for details
---------------------------------------------------------------------------------------------------------------------------------
1.8.9 Version:
Please report them here and use [1.8] in the title.
Requires Galacticraft 4 Builds, (178 Build and higher) and Forge 11.15.1.1764 or higher & Requires MJRLegendsLib as of ExtraPlanets v1.1.9!

v1.4.8 is available, check change log for details.
---------------------------------------------------------------------------------------------------------------------------------
 

MJRLegends

Member
Mar 13, 2015
540
63
28
---------------------------------------------------------------------------------------------------------------------------------
1.12.2 Version:
Please report them here and use [1.12.2] in the title.
Requires Galacticraft 4 Builds, (178 Build and higher) and Forge 14.23.1.2555 or higher & Requires MJRLegendsLib as of ExtraPlanets!

v0.4.4 is available, check change log for details.
---------------------------------------------------------------------------------------------------------------------------------
1.11.2 Version
Please report them here and use [1.11.2] in the title.
Requires Galacticraft 4 Builds, (178 Build and higher) and Forge 13.20.1.2513 or higher & Requires MJRLegendsLib as of ExtraPlanets v0.5.0!

v0.8.1 is available, check change log for details
---------------------------------------------------------------------------------------------------------------------------------
1.10.2 Version
Please report them here and use [1.10.2] in the title.
Requires Galacticraft 4 Builds, (178 Build and higher) and Forge 12.18.3.2239 or higher & Requires MJRLegendsLib as of ExtraPlanets v0.8.6!

v1.1.6 is available, check change log for details
---------------------------------------------------------------------------------------------------------------------------------
1.8.9 Version:
Please report them here and use [1.8] in the title.
Requires Galacticraft 4 Builds, (178 Build and higher) and Forge 11.15.1.1764 or higher & Requires MJRLegendsLib as of ExtraPlanets v1.1.9!

v1.4.9 is available, check change log for details.
---------------------------------------------------------------------------------------------------------------------------------