FTB Monster crash when arriving at moon/mars

Discussion in 'Support' started by danielcb114, Dec 30, 2013.

  1. danielcb114

    danielcb114 Member

    Joined:
    Dec 30, 2013
    Messages:
    2
    Likes Received:
    0
    I have posted the crash log, a screenshot and a list of the mods that the FTB Monster pack adds. I am running Minecraft 1.6.4. I'll be happy to provide any more information that might be helpful. Thank you all in advance for your time and help:)


    Here's a list of mods that the pack currently includes
    https://feedthebeast.atlassian.net/wiki/display/PML/Monster

    Code:
    Description: Ticking memory connection
    
    java.lang.RuntimeException: Already decorating!!
        at micdoodle8.mods.galacticraft.moon.world.gen.GCMoonBiomeDecorator.decorate(GCMoonBiomeDecorator.java:46)
        at micdoodle8.mods.galacticraft.moon.world.gen.GCMoonChunkProvider.decoratePlanet(GCMoonChunkProvider.java:340)
        at micdoodle8.mods.galacticraft.moon.world.gen.GCMoonChunkProvider.func_73153_a(GCMoonChunkProvider.java:362)
        at net.minecraft.world.gen.ChunkProviderServer.func_73153_a(ChunkProviderServer.java:258)
        at net.minecraft.world.chunk.Chunk.func_76624_a(Chunk.java:1243)
        at net.minecraft.world.gen.ChunkProviderServer.func_73158_c(ChunkProviderServer.java:153)
        at net.minecraft.server.management.PlayerInstance.<init>(PlayerInstance.java:51)
        at net.minecraft.server.management.PlayerManager.getOrCreateChunkWatcher(PlayerManager.java:193)
        at net.minecraft.server.management.PlayerManager.func_72685_d(PlayerManager.java:370)
        at net.minecraft.server.management.ServerConfigurationManager.func_72358_d(ServerConfigurationManager.java:282)
        at net.minecraft.network.NetServerHandler.func_72498_a(NetServerHandler.java:405)
        at net.minecraft.network.packet.Packet10Flying.func_73279_a(SourceFile:136)
        at net.minecraft.network.MemoryConnection.func_74428_b(MemoryConnection.java:89)
        at net.minecraft.network.NetServerHandler.func_72570_d(NetServerHandler.java:141)
        at net.minecraft.network.NetworkListenThread.func_71747_b(NetworkListenThread.java:54)
        at net.minecraft.server.integrated.IntegratedServerListenThread.func_71747_b(IntegratedServerListenThread.java:109)
        at net.minecraft.server.MinecraftServer.func_71190_q(MinecraftServer.java:691)
        at net.minecraft.server.MinecraftServer.func_71217_p(MinecraftServer.java:587)
        at net.minecraft.server.integrated.IntegratedServer.func_71217_p(IntegratedServer.java:175)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:484)
        at net.minecraft.server.ThreadMinecraftServer.run(SourceFile:583)
    
    
    A detailed walkthrough of the error, its code path and all known details is as follows:
    ---------------------------------------------------------------------------------------
    
    -- Head --
    Stacktrace:
        at micdoodle8.mods.galacticraft.moon.world.gen.GCMoonBiomeDecorator.decorate(GCMoonBiomeDecorator.java:46)
        at micdoodle8.mods.galacticraft.moon.world.gen.GCMoonChunkProvider.decoratePlanet(GCMoonChunkProvider.java:340)
        at micdoodle8.mods.galacticraft.moon.world.gen.GCMoonChunkProvider.func_73153_a(GCMoonChunkProvider.java:362)
        at net.minecraft.world.gen.ChunkProviderServer.func_73153_a(ChunkProviderServer.java:258)
        at net.minecraft.world.chunk.Chunk.func_76624_a(Chunk.java:1243)
        at net.minecraft.world.gen.ChunkProviderServer.func_73158_c(ChunkProviderServer.java:153)
        at net.minecraft.server.management.PlayerInstance.<init>(PlayerInstance.java:51)
        at net.minecraft.server.management.PlayerManager.getOrCreateChunkWatcher(PlayerManager.java:193)
        at net.minecraft.server.management.PlayerManager.func_72685_d(PlayerManager.java:370)
        at net.minecraft.server.management.ServerConfigurationManager.func_72358_d(ServerConfigurationManager.java:282)
        at net.minecraft.network.NetServerHandler.func_72498_a(NetServerHandler.java:405)
        at net.minecraft.network.packet.Packet10Flying.func_73279_a(SourceFile:136)
        at net.minecraft.network.MemoryConnection.func_74428_b(MemoryConnection.java:89)
        at net.minecraft.network.NetServerHandler.func_72570_d(NetServerHandler.java:141)
    
    -- Ticking connection --
    Details:
        Connection: [email protected]
    Stacktrace:
        at net.minecraft.network.NetworkListenThread.func_71747_b(NetworkListenThread.java:54)
        at net.minecraft.server.integrated.IntegratedServerListenThread.func_71747_b(IntegratedServerListenThread.java:109)
        at net.minecraft.server.MinecraftServer.func_71190_q(MinecraftServer.java:691)
        at net.minecraft.server.MinecraftServer.func_71217_p(MinecraftServer.java:587)
        at net.minecraft.server.integrated.IntegratedServer.func_71217_p(IntegratedServer.java:175)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:484)
        at net.minecraft.server.ThreadMinecraftServer.run(SourceFile:583)
    A Screenshot of what happens when I go to mars/the moon(haven't yet tried space stations, I assume it will be the same)
    [​IMG]
     
  2. IsoMS

    IsoMS Member

    Joined:
    Jul 26, 2013
    Messages:
    970
    Likes Received:
    72

    That happens to everyone, its just the world loading.

    after 5 seconds you should appear inside an lunar lander
     
  3. danielcb114

    danielcb114 Member

    Joined:
    Dec 30, 2013
    Messages:
    2
    Likes Received:
    0
    My apologies for the late reply. I I shouldn't have assumed; I tested the mod more, and the space station works perfectly(which is actually perfect, since this is the only feature that interested me). Still, I'm still interested in how to fix it, if someone knows how; or I'll just keep this here as a reference. Thanks for your help!
     
  4. DaddyRoxx

    DaddyRoxx Member

    Joined:
    Dec 2, 2013
    Messages:
    17
    Likes Received:
    1
    .
    Does anyone have a fix for this? I have installed Galacticraft 2.0 in the latest (ver. 1.0.4) Monster modpack. I can get the rocket to launch, but the server crashes with the identical errors above while landing. I assume the server is crashing while generating the Moon world.
    .
    I also have configuration files to de-conflict the ItemID's if anyone is interested.
    .
     
  5. sbreen

    sbreen Member

    Joined:
    Jan 9, 2014
    Messages:
    11
    Likes Received:
    2
    I have the same issue, when going to the moon, prior to getting the landing craft and descent stage the server crashes, I've tested this in single player and on my multiplayer server same thing each time. I've been looking into it a little more and the crash doesn't happen with most of the mods disabled, I'll continue adding them one by one back to the pack and test with a fresh world each time and see if i can find the issue.

    so far works fine with these mods running:
    • ChickenChunks 1.3.3.3
    • CodeChickenCore 0.9.0.7
    • Galacticraft-1.6.4-2.0.2.800
    • Galacticraft-Planets-1.6.4-2.0.2.800
    • MicdoodleCore-1.6.4-2.0.2.800
    • neiaddons-1.6.2-1.9.3.r47
    • NEIPlugins-1.1.0.6
    • NotEnoughItems 1.6.1.8
    • [1.6.4]ReiMinimap_v3.4_01

    I'll keep you updated :)
     
  6. sbreen

    sbreen Member

    Joined:
    Jan 9, 2014
    Messages:
    11
    Likes Received:
    2
    OK, Seems the issue is with CoFH core, I can now travel to and from the moon with no issues :)

    A quick and dirty work-around is to have the following mods disabled:
    • CoFHCore-2.0.0.2
    • EnhancedPortals_3.0.0_Beta-2d
    • RedstoneArsenal-1.0.0.0
    • ThermalExpansion-3.0.0.2
    I'm presuming that the issue is with world gen I'll have a look at changing some of the configs and see what I find.
     
  7. DaddyRoxx

    DaddyRoxx Member

    Joined:
    Dec 2, 2013
    Messages:
    17
    Likes Received:
    1
    Thanks!! I was able to go back to the Moon and Mars with those four mods re-enabled, but as soon as I moved around and a new chunk was generated - server crash.
    .
    So the problem appears to be some sort of conflict during chunk generation of the Moon or Mars. Once the chunks are generated, it appears to work.
    .
     
    #7 DaddyRoxx, Jan 9, 2014
    Last edited: Jan 9, 2014
  8. sbreen

    sbreen Member

    Joined:
    Jan 9, 2014
    Messages:
    11
    Likes Received:
    2
    I've added modified config files that work for me, I've tested them in single player and multi/server with the mods re-enabled and it seems to work fine I could travel to the moon without issues.

    What I did:
    Found configs from an earlier version of a modpack that was working with CoFH enabled
    Diffed the files to find out what was changed
    Removed the modified ore-gen from CoFH and made the specific mods be responsible for their own generation again (hope I didn't miss any).

    Before making the changes I strongly suggest you back-up first as I'm not going to be held responsible for corrupted worlds etc..

    Anyway, hope it helps. Now I can start my new lets play :)
     

    Attached Files:

    BlaizZz likes this.
  9. DaddyRoxx

    DaddyRoxx Member

    Joined:
    Dec 2, 2013
    Messages:
    17
    Likes Received:
    1
    Thanks Sbreen!!! My current server is clearly labelled "Beta" and my players know that. I'll try out your config files and report back.
    .
    Hopefully we can get all of this stable soon. .
    .
     
  10. DaddyRoxx

    DaddyRoxx Member

    Joined:
    Dec 2, 2013
    Messages:
    17
    Likes Received:
    1
    Sbreen,

    Your config fixes worked!!
     
  11. Shekky

    Shekky Member

    Joined:
    Jan 18, 2014
    Messages:
    11
    Likes Received:
    1
    Configs worked for me as well for both client and server. I'm also running FTB Monster 1.0.3 with latest version of Galacticraft
     
    #11 Shekky, Jan 18, 2014
    Last edited: Jan 18, 2014
  12. DaddyRoxx

    DaddyRoxx Member

    Joined:
    Dec 2, 2013
    Messages:
    17
    Likes Received:
    1
    .
    I updated Monster to ver. 1.0.5 and the configs crashed the server again. I'm not going to mess around with adding G-craft to Monster until Monster goes to stable. Too much pain and suffering . .
    .
     
  13. sbreen

    sbreen Member

    Joined:
    Jan 9, 2014
    Messages:
    11
    Likes Received:
    2
    When you update it will have overwritten the config files, just copy the files across again and it'll work.
     
    CJayster likes this.
  14. DaddyRoxx

    DaddyRoxx Member

    Joined:
    Dec 2, 2013
    Messages:
    17
    Likes Received:
    1
    If it was just me, I'd do it, but I have about 5-8 regulars and its tough getting everyone on the same page using manual configs. I'll wait until stable and then give out one set of files / folders.
     
  15. DaddyRoxx

    DaddyRoxx Member

    Joined:
    Dec 2, 2013
    Messages:
    17
    Likes Received:
    1
    Can I make a "Private Pack" and have all of the mods and config files/folders download for my players automagically?
     
  16. TheWhiteTyger

    TheWhiteTyger Member

    Joined:
    Jan 28, 2014
    Messages:
    91
    Likes Received:
    4
    Thank you so much for this guidance. Now I got Galacticraft working with Monster 1.0.7 with Ars Magica 2, Archamedes' Ships, Morph, and now Galacticraft. Thanks a million!
     
  17. DaddyRoxx

    DaddyRoxx Member

    Joined:
    Dec 2, 2013
    Messages:
    17
    Likes Received:
    1
    I'm holding off until Monster is "Stable". Each update adds or deletes mods and I feel I'm chasing my tail getting Galacticraft to work.
     
  18. TheWhiteTyger

    TheWhiteTyger Member

    Joined:
    Jan 28, 2014
    Messages:
    91
    Likes Received:
    4
    That's why the players on our server decided to stick with 1.0.7 since we have more than Galacticraft added in until the team gets Monster updated a few more significant times. But for now we are extremely happy.
     
  19. geegee

    geegee Member

    Joined:
    Jan 26, 2014
    Messages:
    35
    Likes Received:
    9
    For anyone still having problems with this the crash is not caused by galacticraft but by gascraft.
    Gascraft cant work with flatbedrock currently. So to fix it all you have to do is go to the config/cofh/CoFHWorld.cfg and set B:FlatBedrock to false. :)

    Tested it on Monster 1.0.9 multi and singleplayer
     
  20. TheWhiteTyger

    TheWhiteTyger Member

    Joined:
    Jan 28, 2014
    Messages:
    91
    Likes Received:
    4
    Nice update, thank you, now we have to update our server and re-do the config files from sbreen's magic config files. lol
     

Share This Page